strip (without flags) mangles shared objects

VERIFIED FIXED

Status

SeaMonkey
Build Config
P3
normal
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: lidl, Assigned: cls)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
When building the nightly snapshots of the browser, I have
run into problems building with --enable-strip-libs turned on
in my .mozconfig file.

Basically, this means that "strip" gets called on each of
the shared objects that gets built, which (at least under BSD/OS 4.X)
causes the files to be damaged and unusable for further use
with "ld".  This is because "strip" needs the "-d" argument
to only remove debugging symbols under BSD/OS, as opposed to
all symbols.

The problem that I have is there is no way to specify a flag
that should be passed to strip in the build system.  Specifically,
in /cvsroot/mozilla/config/autoconf.mk.in

If I change the "STRIP = @STRIP@" line to be
"STRIP = @STRIP@ -d" then I get a working build.

I guess what I'm asking for is a way to specify a set of
flags to strip in the build system, that can be overridden on
an OS by OS basis.

Thanks.

-Kurt
setting status to new.  This is indeed the way strip behaves on BSD.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

18 years ago
Priority: -- → P3
(Assignee)

Comment 2

18 years ago
Setting milestones to Future.
(Assignee)

Comment 3

18 years ago
Checked in a fix for this a couple of days ago.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 4

18 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.