Facebook in mobile firefox on tablet returns mobile version

RESOLVED DUPLICATE of bug 762960

Status

RESOLVED DUPLICATE of bug 762960
7 years ago
7 years ago

People

(Reporter: cshields, Unassigned)

Tracking

(Depends on: 1 bug)

Trunk
ARM
Android

Details

(Reporter)

Description

7 years ago
With mobile firefox on a tablet device (tested with Xoom and now Asus Transformer), facebook will return its mobile version.  Yet, with the android browser you get the full version.

There is nothing wrong with the full version in mobile firefox, I've used an addon to change my user agent.  But, maybe this is a problem in the user agent itself?   Feel free to WONTFIX this if the problem is on their end, I've submitted a bug with them, hoping they take it seriously.
The user-agent does not provide any way for servers to know whether Firefox for Android is running on a small handheld device or a large tablet.  This is bug 680886.  For now, the only way for Facebook to fix this is to detect the screen size in CSS or JS, or to provide a link for users to switch between mobile and desktop versions.

Thanks for contacting Facebook - please update this bug if you get any response.
Depends on: 680886
(Reporter)

Comment 2

7 years ago
Yeah, I am curious as to how they differentiate right now between the phone android browser and tablet android browser.  This behavior has been present since I first got the xoom months ago, even before the tab bar on the left was introduced.  (I mention that just in case there is a thought that the screen size may be just small enough now to tip the threshold)

will let you know!
I will talk to someone on Facebook's Mobile Team next week to see if they have any interest in fixing.
Feel free to add a followup in bug 762960.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 762960
You need to log in before you can comment on or make changes to this bug.