Closed Bug 687072 Opened 8 years ago Closed 8 years ago

Investigate potential benefits of Windows 8 metro interface with regards to touch

Categories

(Core :: Widget: Win32, defect)

x86_64
Windows 8.1
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 745071

People

(Reporter: bbondy, Unassigned)

References

Details

From Bug 686835 Terepin mentioned:

> ...Metro was created for better user touch experience than Aero can provide.

I don't know if there are benefits or not, but I'm posting this to find out.

This ticket is to investigate which capabilities exactly are supported in Metro which are not supported in the classic Desktop interface. 

In particular, we need to know the exact API differences which produce better multi touch support in Windows 8 metro.
Depends on: 686835
So it seems that the main thing here is to keep consistent with the gestures and feel of Windows 8.

There are 7 Standard set of gestures in Metro apps:
- Press and hold (to learn more)
- Tap (click)
- Slide (to drag)
- Swipe on something (to select or pin the item)
- Pinch (to zoom)
- Swipe from left or right edge for system UI
- Rotate with index finger and thumb like turning a knob (to rotate)
Multi touch, you can drag an item with one finger to pin it up, and then scroll with another finger.
(In reply to Brian R. Bondy [:bbondy] from comment #0)
> From Bug 686835 Terepin mentioned:
> 
> > ...Metro was created for better user touch experience than Aero can provide.
> 
> I don't know if there are benefits or not, but I'm posting this to find out.
> 
> This ticket is to investigate which capabilities exactly are supported in
> Metro which are not supported in the classic Desktop interface. 
> 
> In particular, we need to know the exact API differences which produce
> better multi touch support in Windows 8 metro.

Metro only gives integration with the swipy "multitasking" switcher, live tile integration, and win store updates.  Full touchscreen access is available in desktop mode.  There might also be libraries in WinRT that make handling touch easier, but I doubt they will have too much of an impact.
OS: Windows 8 → Windows 8 Metro
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 745071
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.