Last Comment Bug 687085 - Add Telemetry for hit rate & revalidation rate per cache type
: Add Telemetry for hit rate & revalidation rate per cache type
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Networking: Cache (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla10
Assigned To: Nicholas Hurley [:nwgh][:hurley]
:
: Patrick McManus [:mcmanus]
Mentors:
Depends on: 736844
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-16 09:37 PDT by Nicholas Hurley [:nwgh][:hurley]
Modified: 2012-03-18 07:51 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (5.89 KB, patch)
2011-09-30 13:46 PDT, Nicholas Hurley [:nwgh][:hurley]
mcmanus: review+
Details | Diff | Splinter Review

Description Nicholas Hurley [:nwgh][:hurley] 2011-09-16 09:37:09 PDT
+++ This bug was initially created as a clone of Bug #686948 +++

We want to collect telemetry for the following bits of information (for each of memory/disk/offline cache in this case):

Cache hit (without revalidation from the server)
Successful revalidation (hit with network overhead)
Failed revalidation (we have an entry but after asking the server it can no longer be used)
Cache miss (no entry in the cache)
Comment 1 Geoff Brown [:gbrown] 2011-09-28 11:30:03 PDT
To clarify, do we want something like:

-HISTOGRAM(HTTP_CACHE_DISPOSITION, 1, 5, 5, LINEAR, "HTTP Cache Hit, Reval, Failed-Reval, Miss")

+HISTOGRAM(HTTP_DISK_CACHE_DISPOSITION, 1, 5, 5, LINEAR, "HTTP Cache Hit, Reval, Failed-Reval, Miss")
+HISTOGRAM(HTTP_MEMORY_CACHE_DISPOSITION, 1, 5, 5, LINEAR, "HTTP Cache Hit, Reval, Failed-Reval, Miss")
+HISTOGRAM(HTTP_OFFLINE_CACHE_DISPOSITION, 1, 5, 5, LINEAR, "HTTP Cache Hit, Reval, Failed-Reval, Miss")

?
Comment 2 Nicholas Hurley [:nwgh][:hurley] 2011-09-28 11:37:47 PDT
My intention was to keep the original HTTP_CACHE_DISPOSITION telemetry, and add in the other 3.

I was actually working on this one this morning (don't know why I hadn't assigned it to myself, but you doing it is fine) and got to thinking that having a "pure miss" count by device type may not work anyway (since we wouldn't have a cache entry to figure out what cache device to mark), unless we wanted to count it as a miss on all device types (which while technically correct, may end up skewing our view of things). So perhaps we should just do hit/reval/failed-reval for the device-specific bins? I'm open to suggestions.
Comment 3 Nicholas Hurley [:nwgh][:hurley] 2011-09-29 09:57:11 PDT
Reassigning after discussion w/Geoff
Comment 4 Nicholas Hurley [:nwgh][:hurley] 2011-09-30 13:46:33 PDT
Created attachment 563834 [details] [diff] [review]
patch

Extends the work we already did for general disposition, and adds device-specific counts.
Comment 5 Nicholas Hurley [:nwgh][:hurley] 2011-10-03 09:38:35 PDT
https://tbpl.mozilla.org/?tree=Try&usebuildbot=1&rev=cc8d1fd89bac
Comment 6 Nicholas Hurley [:nwgh][:hurley] 2011-10-03 16:22:45 PDT
It seems to me as if try is fine (still new at figuring this all out...)
Comment 8 Ed Morley [:emorley] 2011-10-07 05:09:39 PDT
https://hg.mozilla.org/mozilla-central/rev/a516cf2d48f6

Note You need to log in before you can comment on or make changes to this bug.