All users were logged out of Bugzilla on October 13th, 2018

Add new filter/edit existing one duplicates filters list.

VERIFIED WORKSFORME

Status

P1
major
VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: laurel, Assigned: gayatrib)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Using feb13 commercial trunk build, linux rh6.0, win98 

When you add a New filter to an account with existing filters, upon OK to the
filter rules dialog the main dialog's list of filters is duplicated.

1.  Edit|Filters, select an account with existing filters.
2.  Click New, set up a simple filter, clic OK to the filter rules dialog.

Result:  new filter is added to list and the existing list is duplicated.

Expected:  new filter is added to list, existing list unchanged.
(Reporter)

Comment 1

18 years ago
Note:  the display list is affected, but duplicates are not written to rules.dat
Keywords: nsbeta1
Priority: -- → P1
QA Contact: esther → laurel
(Reporter)

Comment 2

18 years ago
Also happens when editing an existing filter.
Summary: Add new filter duplicates filters list. → Add new filter/edit existing one duplicates filters list.
(Reporter)

Comment 3

18 years ago
Eek.  Also happens when enabling or disabling a filter.
Duplications keep happening on each New/Edit/disable/enable within a session of
the filters dialog. Launch again appears to clear the display duplication.

Comment 4

18 years ago
*** Bug 68774 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
This wasn't working for me previously but is now working for me in 2001021505.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

18 years ago
OK for me using feb 19 comemrcial trunk, all platforms.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.