Last Comment Bug 687174 - Strange swype deletion behaviour on Galaxy Tablet
: Strange swype deletion behaviour on Galaxy Tablet
Status: RESOLVED DUPLICATE of bug 672661
[vkb]
: inputmethod
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Firefox 7
: ARM Android
: -- normal (vote)
: ---
Assigned To: Alex Pakhotin (:alexp)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-16 15:18 PDT by Malini Das [:mdas] - Away, not checking bugmail
Modified: 2011-09-23 19:49 PDT (History)
4 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Malini Das [:mdas] - Away, not checking bugmail 2011-09-16 15:18:02 PDT
This is regarding the Samsung Galaxy Tablet. Using Swype in the text field then trying to delete the text with the backspace button does not quite work. If you delete a letter in the swype-generated word, the whole word will reappear. Steps:

1) use swype to enter a word, say 'test'
2) use the backspace button on the keyboard to delete a letter

Expected:
-letter will be deleted and all we will see is 'tes'
What happens:
-letter gets deleted, but the word reappears, so we now see: 'testest'

You can delete it if you do a select all or highlight on the textfield and then use backspace. This really affects my mobile experience because I rely on swype to work with all my apps, so it's pretty crippling to me as a user to use the default keyboard.
Comment 1 Matt Brubeck (:mbrubeck) 2011-09-16 15:22:31 PDT
What version(s) of Firefox are you seeing this in?  Can you reproduce it in Nightly?
Comment 2 Matt Brubeck (:mbrubeck) 2011-09-16 16:42:56 PDT
This looks very similar to bug 672661, although that bug was reported with the SwiftKey X keyboard.
Comment 3 Andrew Halberstadt [:ahal] 2011-09-17 07:26:54 PDT
I notice the same problem. It is reproducible in nightly (haven't tried any other channel)
Comment 4 Alex Pakhotin (:alexp) 2011-09-20 15:40:24 PDT
Can you guys provide more detailed steps please? What website do you see this on? Did you change any Swype options? Do you enter the word by typing letter-by-letter or using one continuous motion through the keys?

I do see some issues when entering text with Swype, but cannot reproduce this issue as described. For example, I'm entering text in Google search box, and I don't have any problem deleting it. I'm just trying to understand if my patch for the bug 672661 improves the situation.

By the way, this again seems to be an IPC-related issue. Looks like the text entering in the chrome process works fine, only the child process is affected.
Comment 5 Andrew Halberstadt [:ahal] 2011-09-20 15:44:04 PDT
Malini's steps are unfortunately pretty much all there is to it.  I type a word, it doesn't matter if it's in the address bar, or into an input box on a website.  I then press backspace and Malini's described behaviour happens.
Comment 6 Alex Pakhotin (:alexp) 2011-09-20 15:53:02 PDT
OK, what version of Fennec are you using? I tried Aurora, Nightly-9-15, the latest Nightly, my own build - don't see the described behavior. The address bar doesn't have any problem at all. There are some issues in the search box on google.com, but not as described.
What version of Swype do you have? Mine, which comes with Galaxy Tab, is: 3.9.86.27849.2113.P4_WIFI
Comment 7 Andrew Halberstadt [:ahal] 2011-09-23 07:37:35 PDT
Hm, my version of Swype is 3.25.91.31127 (it didn't come with my Asus Transformer, I had to download it from their website).  I'll see if I can upgrade.
Comment 8 Andrew Halberstadt [:ahal] 2011-09-23 07:49:23 PDT
According to the Swype website (http://beta.swype.com/), version 3.25 is the latest beta release. I also just upgraded to the latest nightly (20110923) and still have the same issue.
Comment 9 Andrew Halberstadt [:ahal] 2011-09-23 07:53:51 PDT
It looks like this issue isn't specific to Fennec and/or tablets: http://forum.swype.com/showthread.php?4484-Backspace-will-auto-copy-words-to-be-deleted-and-paste-it-automatically-on-Galaxy-S2&highlight=firefox
Comment 10 Andrew Halberstadt [:ahal] 2011-09-23 07:57:30 PDT
Sorry for the bug spam.. but this comment from the forum may be relevant:

> Unfortunately that looks like an application bug in the text field to me- it's supposed to
> delete the original word and replace it with the underlined version, it appears to not have 
> done the deletion. That's likely a result of the application not supporting the
> InputConnection call we use, but still claiming it does by returning true. There's not a lot > we can do for that, although I'm very surprised this bug hasn't crossed my desk before now.
Comment 11 Jim Chen [:jchen] [:darchons] 2011-09-23 09:14:48 PDT
(In reply to Andrew Halberstadt [:ahal] from comment #10)
> > That's likely a result of the application not supporting the
> > InputConnection call we use, but still claiming it does by returning true.

Bug 672661 has alexp's patch to implement the missing call. Maybe you can try a build with that patch? I can put up a build if you don't have a Fennec build env.
Comment 12 Alex Pakhotin (:alexp) 2011-09-23 10:25:30 PDT
(In reply to Andrew Halberstadt [:ahal] from comment #10)
> > That's likely a result of the application not supporting the
> > InputConnection call we use...

Yes, this definitely sounds like the same problem as in the bug 672661.
My patch for that bug was approved, I'm going to push it today.

I just wanted to see the problem as described here myself first to make sure the patch actually fixes it. Apparently I need a newer version of Swype.
Comment 13 Alex Pakhotin (:alexp) 2011-09-23 13:49:46 PDT
OK, the patch from bug 672661 definitely fixes the issue, but I've found some change submitted around Sep 20-21 made text input with Swype much worse. Looks like each character is now treated as a separate word.
Nightly 20110920030905 (SourceStamp=648d084ca28e) is OK, but the next nightly 20110921030906 (SourceStamp=e8bd19f6abbb) has this worse behavior.
Comment 14 Jim Chen [:jchen] [:darchons] 2011-09-23 14:00:38 PDT
(In reply to Alex Pakhotin (:alexp) from comment #13)
> OK, the patch from bug 672661 definitely fixes the issue, but I've found
> some change submitted around Sep 20-21 made text input with Swype much
> worse. Looks like each character is now treated as a separate word.
> Nightly 20110920030905 (SourceStamp=648d084ca28e) is OK, but the next
> nightly 20110921030906 (SourceStamp=e8bd19f6abbb) has this worse behavior.

Bug 685537? But that only prevents key events with meta set from reaching the IME.
Comment 15 Alex Pakhotin (:alexp) 2011-09-23 19:46:18 PDT
(In reply to Alex Pakhotin (:alexp) from comment #13)
> Nightly 20110920030905 (SourceStamp=648d084ca28e) is OK

After more testing I'm not so sure about this. The older nightlies have the same problems, and the behavior is not very consistent. One thing I'm certain about, it's related to IPC, as typing in the chrome process (address bar, for example) is fine.
That is not related to this bug though, it's probably again bug 653895.
Comment 16 Alex Pakhotin (:alexp) 2011-09-23 19:49:18 PDT
Marking it as duplicate as it's essentially the same as the bug 672661.

*** This bug has been marked as a duplicate of bug 672661 ***

Note You need to log in before you can comment on or make changes to this bug.