print to postscript from command line

RESOLVED DUPLICATE of bug 100571

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 100571
18 years ago
15 years ago

People

(Reporter: luis, Assigned: rods)

Tracking

({helpwanted})

Trunk
Future
x86
Linux
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
So... mozilla has (by far) the best HTML->postscript conversion of any Unix
tool. It would be nice to be able to do something like "mozilla --print
source.html target.ps" and have mozilla render and generate a postscript file
from source.html, without having to bring up a window or even be running X. This
would allow (for example) the use of mozilla (or perhaps a new executable,
mozprint) as part of a script to generate printed versions of web pages for
documentation or things like that. Since there really aren't any other decent
tools for printing modern HTML (html2ps stinks), this would be a really useful
tool for the Unix community to have.
One note.  Implementing this may involve some changes to the printing
interfaces. Right now the nsIDeviceSpecPS interface and the ndIDeviceSpecGTK (or
QT, or xlib, or whatever) interface are not completely independent as far as I
can tell.  They would need to be in order for this to work without running X. 
Ideally, the mozprint program should run on a machine without any graphics
toolkit or X to link against...

Comment 2

18 years ago
This is a future capability.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → LATER
Target Milestone: --- → Future

Comment 3

18 years ago
*** Bug 73899 has been marked as a duplicate of this bug. ***

Comment 4

18 years ago
See also bug 5702, [rfe] print directly to printer from command line.
Summary: [RFE]ability to use printing capabilites from the command line for scripting → [RFE] print to postscript from command line
LATER is deprecated per bug 35839.
Status: RESOLVED → REOPENED
Resolution: LATER → ---
->rods
Assignee: dcone → rods
Status: REOPENED → NEW
Keywords: helpwanted

Updated

16 years ago
Summary: [RFE] print to postscript from command line → print to postscript from command line

Comment 7

16 years ago
anybody working on this?
If someone were working on this:

1) They would have said so in the bug
2) There would be a target milestone
3) The bug status would almost certainly be "ASSIGNED"
4) There would almost certainly be no "helpwanted" keyword.  That keyword
   means "no one is interested in working on this; if you are, speak up."

So the answer is "No".

Comment 9

16 years ago
I would really like to have that feature.
Then you should convince (eg pay) someone to implement it.  Complaining in the
bug won't accomplish that.

Comment 11

15 years ago
This and bug 100571 are requesting the same feature. That bug has some more
detailed discussion, so I'm resolving this one as a dup.

*** This bug has been marked as a duplicate of 100571 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.