Filter "Containt contains ok" does not respond if short keyword is at the message's end

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: burninleo, Unassigned)

Tracking

({testcase})

x86
Windows Vista
testcase

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dupeme?)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 560699 [details]
Message Source (sensible information replaces by dummies)

User Agent: Mozilla/5.0 (Windows NT 6.0; rv:6.0.2) Gecko/20100101 Firefox/6.0.2
Build ID: 20110902133214

Steps to reproduce:

1. Create a filter for an account
2. Inhalt (content) - enthält (contains) - ok
3. The messages to filter contains an "ok" the the very end of the text message. According to the sourcecode of the mail the only following bytes were a few newlines (see sample message attached, domain names have been replaced by a dummy)


Actual results:

The filter did not respond until this specific condition was removed.
- Suggestion 1: The filter did not respond because the "ok" was at the very end of the file
- Suggestion 2: The filter did not respond because "ok" only has two characters


Expected results:

The filter should respond to the message or a message should be shown that "ok" is too short (if that was the problem)
YOu are filtering on the body content right ?
Component: General → Filters
Product: Thunderbird → MailNews Core
QA Contact: general → filters
Whiteboard: dupme
(Reporter)

Comment 2

7 years ago
Yes, that is correct. The filter should search in the email's content. The "ok" is at the very end of the content (and of the email's sourcecode as it is a simple text mail).
Keywords: testcase

Comment 3

7 years ago
I imported the test message and created a filter as you describe, to copy the matching message into Local folders/Trash. I then manually run filters on the folder containing the message. 
Everything worked fine. Message was copied from POP3 account to Local folders and also in the opposite direction (when I changed the filters). This was on TB10, Win XP.

But why is there duplicate definition of content-type in the message headers? Just curious, it doesn't seem to be a problem, the second one is handled at part of the message body (it is separated from the real header with an empty line).

Comment 4

5 years ago
WFM per comment 3.
Please reopen if you still see this
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Whiteboard: dupme → dupeme?
You need to log in before you can comment on or make changes to this bug.