Last Comment Bug 687298 - Preference checkboxes re-toggling on tap
: Preference checkboxes re-toggling on tap
Status: VERIFIED FIXED
: regression
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Firefox 9
: ARM Android
: -- major (vote)
: Firefox 9
Assigned To: Matt Brubeck (:mbrubeck)
:
:
Mentors:
: 687794 (view as bug list)
Depends on:
Blocks: 660686
  Show dependency treegraph
 
Reported: 2011-09-17 17:26 PDT by Aaron Train [:aaronmt]
Modified: 2011-09-21 13:01 PDT (History)
5 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch (2.09 KB, patch)
2011-09-19 09:26 PDT, Matt Brubeck (:mbrubeck)
mark.finkle: review+
Details | Diff | Splinter Review

Description Aaron Train [:aaronmt] 2011-09-17 17:26:04 PDT
Mozilla/5.0 (Android; Linux armv7l; rv:9.0a1) Gecko/20110917 Firefox/9.0a1 Fennec/9.0a1

Tapping a preference checkbox re-toggles it's state thus making no change.

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=39b192706927&tochange=85fb038d1dd1

Guessing a regression from either:
http://hg.mozilla.org/mozilla-central/rev/56a5de4a7413 
http://hg.mozilla.org/mozilla-central/rev/94182039abda
Comment 1 Aaron Train [:aaronmt] 2011-09-18 21:50:46 PDT
For the record, this is when one taps directly on the checkbox.
Comment 2 Matt Brubeck (:mbrubeck) 2011-09-19 09:23:09 PDT
Sorry, stealing this because I started working on a patch before I saw it was assigned.
Comment 3 Matt Brubeck (:mbrubeck) 2011-09-19 09:26:48 PDT
Created attachment 560937 [details] [diff] [review]
patch

Prevents the click event from reaching the checkbox.
Comment 4 Mark Finkle (:mfinkle) (use needinfo?) 2011-09-19 09:42:05 PDT
Comment on attachment 560937 [details] [diff] [review]
patch

stealing review
Comment 5 Matt Brubeck (:mbrubeck) 2011-09-19 16:09:32 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/1db035c0e495
Comment 6 Matt Brubeck (:mbrubeck) 2011-09-20 07:41:51 PDT
*** Bug 687794 has been marked as a duplicate of this bug. ***
Comment 8 Cristian Nicolae (:xti) 2011-09-21 05:45:47 PDT
Verified fixed on:
Mozilla/5.0 (Android;Linux armv7l;rv:9.0a1)Gecko/20110921
Firefox/9.0a1 Fennec/9.0a1
Device: Samsung Galaxy S
OS: Android 2.2

Note You need to log in before you can comment on or make changes to this bug.