Last Comment Bug 687389 - MSVC 2010 warning C4005: '_WIN32_WINNT' : macro redefinition for various files under accessible/public/*
: MSVC 2010 warning C4005: '_WIN32_WINNT' : macro redefinition for various file...
Status: RESOLVED FIXED
[build_warning]
:
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: mozilla9
Assigned To: Ed Morley [:emorley]
:
Mentors:
Depends on:
Blocks: buildwarning
  Show dependency treegraph
 
Reported: 2011-09-18 17:37 PDT by Ed Morley [:emorley]
Modified: 2011-09-23 04:54 PDT (History)
5 users (show)
emorley: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (1.39 KB, patch)
2011-09-18 18:03 PDT, Ed Morley [:emorley]
surkov.alexander: review+
Details | Diff | Splinter Review

Description Ed Morley [:emorley] 2011-09-18 17:37:39 PDT
MSVC 2010 using http://hg.mozilla.org/integration/mozilla-inbound/rev/f827e9173fea

{
ISimpleDOMDocument_i.c
c:\mozilla\repos\obj-inbound\accessible\public\msaa\../../../dist/include/mozilla-config.h(91) : warning C4005: '_WIN32_WINNT' : macro redefinition
        command-line arguments :  see previous definition of '_WIN32_WINNT'
ISimpleDOMNode_i.c
c:\mozilla\repos\obj-inbound\accessible\public\msaa\../../../dist/include/mozilla-config.h(91) : warning C4005: '_WIN32_WINNT' : macro redefinition
        command-line arguments :  see previous definition of '_WIN32_WINNT'
...plus more under accessible/public/msaa/
}

{
Accessible2_p.c
c:\mozilla\repos\obj-inbound\accessible\public\ia2\../../../dist/include/mozilla-config.h(91) : warning C4005: '_WIN32_WINNT' : macro redefinition
        command-line arguments :  see previous definition of '_WIN32_WINNT'
AccessibleAction_p.c
c:\mozilla\repos\obj-inbound\accessible\public\ia2\../../../dist/include/mozilla-config.h(91) : warning C4005: '_WIN32_WINNT' : macro redefinition
        command-line arguments :  see previous definition of '_WIN32_WINNT'
...plus ~20 more under accessible/public/ia2/
}

Caused by the |DEFINES += -DREGISTER_PROXY_DLL -D_WIN32_WINNT=0x400| lines here:
http://mxr.mozilla.org/mozilla-central/search?string=_WIN32_WINNT&find=accessible%2Fpublic%2F
Comment 1 Ed Morley [:emorley] 2011-09-18 18:03:38 PDT
Created attachment 560834 [details] [diff] [review]
Patch v1

Removes the _WIN32_WINNT defines in: accessible/public/msaa/Makefile.in and accessible/public/ia2/Makefile.in , which existed at least as far back as CVS days, but seem redundant given the defines that end up in mozilla-config.h.
Comment 2 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-09-19 15:23:27 PDT
Comment on attachment 560834 [details] [diff] [review]
Patch v1

I'd prefer that an a11y peer review this.
Comment 3 alexander :surkov 2011-09-19 16:28:37 PDT
This code is 8 years old (bug 199518) and I didn't find a reason why it was introduced. This define isn't used in sources explicitly but I'm not sure if it can affect on dll creation or registration. What possible value are available and how they are used, do Windows header files rely on it, any hint?
Comment 4 Ed Morley [:emorley] 2011-09-19 16:46:58 PDT
khuey or ted might be able to answer that, adding to CC :-)
Comment 5 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-09-20 04:28:32 PDT
http://msdn.microsoft.com/en-us/library/aa383745%28v=vs.85%29.aspx#setting_winver_or__win32_winnt

It controls what definitions are made available in the Windows headers.
Comment 6 alexander :surkov 2011-09-22 09:21:08 PDT
Comment on attachment 560834 [details] [diff] [review]
Patch v1

r=me
Comment 8 Ed Morley [:emorley] 2011-09-23 04:54:36 PDT
https://hg.mozilla.org/mozilla-central/rev/0c47234a4021

Note You need to log in before you can comment on or make changes to this bug.