Last Comment Bug 68739 - nsIBidiKeyboard.idl related changes
: nsIBidiKeyboard.idl related changes
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: Internationalization (show other bugs)
: Trunk
: All All
: P1 normal (vote)
: mozilla0.9
Assigned To: Erik van der Poel
: Erik van der Poel
: Makoto Kato [:m_kato]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-13 16:02 PST by Frank Tang
Modified: 2005-03-17 13:34 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Frank Tang 2001-02-13 16:02:12 PST
This bug is spin off rom bug 62777 and target on the widget only changes.
IBMBIDI team- please attach the latest changes in mozilla/widget directory here
and we should land this earlier since the code do not depend on other part and
layout chagnes depend on this.
kmcclusk@netscape.com nicely agree to review this tomorrow if you can send him
by tomorrow morning. Thanks.
Comment 1 Kevin McCluskey (gone) 2001-02-14 11:03:33 PST
Changes look ok to me.
r=kmcclusk@netscape.com
Comment 2 Erik van der Poel 2001-02-14 14:13:02 PST
I think we need to add nsIBidiKeyboard.idl to MANFIFEST_IDL. Right, Frank?

There is a missing backslash (\) in beos/Makefile.in.

In the Windows version, when GetKeyboardLayoutList returns an unexpected value,
you need to free buf before returning.
Comment 3 Erik van der Poel 2001-02-14 14:26:33 PST
OK, I've made changes to my local files, and will check them in.

sr=erik
Comment 4 Erik van der Poel 2001-02-14 15:14:20 PST
Checked in.
Comment 5 spambot 2001-02-14 15:23:05 PST
Stupid question, I expect.  Why is it that for all of the platform widgets you
have four files in the platform subdirectory - eg. /qt/ but for windows one of
the files shows in "mozilla/ widget/ src/ build/ nsWinWidgetFactory.cpp" where
the other three are in "mozilla/ widget/ src/ windows/"?


Comment 6 Erik van der Poel 2001-02-14 16:23:12 PST
I don't know. The original author(s) of that file (WinWidgetFactory) might know.
Comment 7 Teruko Kobayashi 2001-02-28 11:42:32 PST
Erik, please mark this bug as verified.
Comment 8 Erik van der Poel 2001-02-28 12:27:24 PST
I verified that all of these files were checked in and are being built.

Note You need to log in before you can comment on or make changes to this bug.