If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Failing Acid2 on fullscreen

RESOLVED DUPLICATE of bug 398763

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 398763
6 years ago
6 years ago

People

(Reporter: Eric Sh., Unassigned)

Tracking

7 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 560865 [details]
Ugly Smiley

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:7.0) Gecko/20100101 Firefox/7.0
Build ID: 20110908135051

Steps to reproduce:

I opened up the acid2 test:
http://acid2.acidtests.org/#top

And went to fullscreen mode


Actual results:

The smiley image became horrifying!


Expected results:

The smiley should have kept smiling.
(Reporter)

Updated

6 years ago

Comment 1

6 years ago
Mozilla/5.0 (Windows NT 5.1; rv:7.0) Gecko/20100101 Firefox/7.0
Mozilla/5.0 (Windows NT 5.1; rv:9.0a1) Gecko/20110918 Firefox/9.0a1

Works for me

Comment 2

6 years ago
WFM too on FF6, Win XP. When does the image corrupt for you? Does it look right in normal mode? And as you went fullscreen it became corrupted? Was the image rerendered by itself? Or did you reload?
wfm with Seamonkey trunk and FF6.0.2
The known problem with zooming at the acid2 looks different.
(Reporter)

Comment 4

6 years ago
I just opened up the test page and the smiley was fine and then I clicked F11 to make it fullscreen and the smiley turned ugly.
The smiley turned bad without reloading but once I reloaded the smiley was ok again.

Is it a known problem? and if so on which side is it on the acid makers or on firefox side?

Comment 5

6 years ago
Can you see if you are using HW acceleration (about:support -> Graphics section). Yes, you are on XP but Direct3D may still be enabled.

Comment 6

6 years ago
(In reply to Eric Sh. from comment #4)
> Is it a known problem? and if so on which side is it on the acid makers or
> on firefox side?

How could anyone here answer this as long nobody here can reproduce this?
(Reporter)

Comment 7

6 years ago
Try to change the browser width to about 640px, and then fullscreen.
If that doesn't work try also about 600px height and fullscreen.

Comment 8

6 years ago
Oh, then I can see it (FF6,XP). It also happens when just resizing the small window to a bigger one or fullscreen. It also happens when loading into a big window and then resizing to a small one (but not resize to fullscreen). It looks like there are some absolutely positioned objects, that depend on the initial window size.
Status: UNCONFIRMED → NEW
Component: General → Layout
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → layout
The width threshhold for whether it breaks is whether "Take The Acid2 Test and compare it to the reference rendering." wraps.

The underlying problem is that we don't maintain anchor scrolling positions when resizing a page, and the acid2 test scrolls to a named anchor and tests that fixed positioned elements and elements with fixed backgrounds line up correctly.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 398763
You need to log in before you can comment on or make changes to this bug.