Load time increases for stats table after a scrolling through the first pages.

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Statistics
RESOLVED WONTFIX
6 years ago
2 years ago

People

(Reporter: Cristian Boldan, Unassigned)

Tracking

unspecified
6.3.1

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:6.0.2) Gecko/20100101 Firefox/6.0.2
Build ID: 20110902133214

Steps to reproduce:

1.	Select statistics for an available add-on – e.g. https://addons-dev.allizom.org/z/en-US/firefox/addon/adblock-plus/statistics/ .
2.	In the Add-on Statistics menu, select “Downloads” or “Daily Users”.
3.	In the “Downloads by Date” click the “Next” button to scroll to next pages.
4.	Repeat step 3.



Actual results:

After the first 20-30 pages, there is a visible increase in load times.


Expected results:

Pages should load without any issues.
(Reporter)

Updated

6 years ago
Blocks: 611705
This happens because we have to load more data. The page only requests as much data as it needs so each page leads to another request. This could be fixed by prefetching larger chunks.
No longer blocks: 611705
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Updated

6 years ago
Blocks: 611705

Updated

6 years ago
Target Milestone: --- → 6.3.1
comment 1 is correct.  Are there any users running into this problem?  I'm doubting anyone is actually going through 30 pages of data without just using the CSVs.

Load times getting slower is expected as we go back into older data.  "visible increase in load time" doesn't sound like a big deal to me.  If we're talking minutes to load the page, reopen, otherwise -> wontfix.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.