Closed Bug 687469 Opened 9 years ago Closed 5 years ago

Multiple empty nodes are appended to history sidebar after opening a website from it

Categories

(Firefox :: Bookmarks & History, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox8 - wontfix

People

(Reporter: mihaelav, Unassigned)

Details

(Keywords: regression, Whiteboard: [qa+])

Attachments

(2 files)

Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0) Gecko/20100101 Firefox/7.0; bet 6
Build ID: 20110916091512

Steps to reproduce:
1. Launch Firefox
2. Open History sidebar
3. Form any section (e.g this month) select a website for whish you have visited various of its pages
4. Colapse the history section (e.g. this month; do NOT close the History sidebar)
5. Expand the same history section again (or other section where the website is present)

Actual result:
Under the website opened at step 3 there are multiple blank nodes appended. Appended nodes are not functional.

Expected result:
All websites under the section are displayed correctly
Build identifier: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:9.0a1) Gecko/20110919 Firefox/9.0a1
Build ID: 20110919030912

The issue is reproducible on Nightly, as well.
Version: 7 Branch → Trunk
Is this a recent regression? Can you get a regression window using the mozregression tool?
FWIW, the workaround is to close and reopen the sidebar.
Asking for tracking-firefox8. I don't think this should block Firefox 7 at this point but we should fix it for Firefox 8 once we identify a regression range.
Whiteboard: [qa+]
Last good nightly: 2010-02-25
First bad nightly: 2010-02-26

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a29d44f196a6&tochan
ge=475768f37b1a
Bug 492797 seems like a likely suspect...

hasHistoryEntries should cache the value instead of hitting the db every time 
http://hg.mozilla.org/mozilla-central/rev/ccdba3c82b65
OS: Windows 7 → All
Hardware: x86_64 → All
will investigate this
Assignee: nobody → mak77
Status: NEW → ASSIGNED
---------------------------------[ Triage Comment ]---------------------------------

We are not tracking this for Firefox 8. We already shipped this in Firefox 6 and 7 and there wasn't a large amount of breakage (no real feedback, no dupes here). Also there is no dataloss it is merely a visual glitch. The history sidebar is also secondary UI so the impact of the glitch is smaller.  

If a safe fix is found please nominate it for aurora and/or beta though.
I seem to be unable to reproduce this bug in current nightly, with steps in comment 0.
I assume the sidebar should be setup "by date and site"?
Should I visit the page or any other step I may have missed?
unassigning till the steps to reproduce are clarified
Assignee: mak77 → nobody
Status: ASSIGNED → NEW
Attached file Video of issue
Issue is still reproducible in the latest nightly with same steps from description:

Steps to reproduce:
1. Launch Firefox
2. Open History sidebar
3. Form any section (e.g this month) select a website for whish you have visited various of its pages (e.g. Youtube, if you watched some youtube videos)- Page should load in browser
4. Colapse the history section (e.g. this month; do NOT close the History sidebar)
5. Expand the same history section again (or other section where the website is present)

Actual result:
Under the website opened at step 3 there are multiple blank nodes appended. Appended nodes are not functional.

Expected result:
All websites under the section are displayed correctly
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.