The mail toolbar not work in modern skin

VERIFIED FIXED

Status

VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: pmac, Assigned: hewitt)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Platform: Windows 98 (2001-02-13-04-Mtrunk).

1. Launch Netscape 6. (Modern skin)
2. Open mail by go to Tasks/Mails/
3. Notice when you click on mail toolbar, it does not work.
However, it works fine in Classic skin.
(Assignee)

Comment 1

18 years ago
works for me
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

18 years ago
Joe, I can reproduce this bug on windows (2001-02-22-14-Mtrunk).

To reproduce: 
1. Launch the commercial trunk build (2001-02-22-14-Mtrunk).
2. Open mail by go to Tasks/Mails/
3. Notice when you click on mail toolbar "New Message", "Reply", "Reply All", 
etc, it does not work and sometimes it crashes.
However, it works fine in Classic skin.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 3

18 years ago
Below here is the talkback report:

Trigger Type:   Program Crash <http://cyclone/images/spacer.gif>   Trigger 
Reason:   Access violation <http://cyclone/images/spacer.gif>
Thread ID:  <http://cyclone/images/spacer.gif> Call Stack:    (Signature = 
MSVCRT.DLL + 0xd16a (0x7800d16a) f89bb0d8)
     MSVCRT.DLL + 0xd16a (0x7800d16a)  
     MSVCRT.DLL + 0x11b77 (0x78011b77)  
     JS_realloc [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 1448]
     js_AllocSlot [d:\builds\seamonkey\mozilla\js\src\jsobj.c, line 1696]
     js_NewScopeProperty [d:\builds\seamonkey\mozilla\js\src\jsscope.c, line 
507]
     js_DefineProperty [d:\builds\seamonkey\mozilla\js\src\jsobj.c, line 1862]
     js_DefineFunction [d:\builds\seamonkey\mozilla\js\src\jsfun.c, line 1766]
     JS_DefineFunction [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 2715]
     JS_DefineFunctions [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 2697]
     JS_InitClass [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 1806]
     NS_InitNodeClass 
[d:\builds\seamonkey\mozilla\dom\src\coreDOM\nsJSNode.cpp, line 1045]
     nsJSContext::InitClasses 
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 1270]
     nsJSContext::InitContext 
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 1040]
     NS_CreateScriptContext 
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 1556]
     nsDocShell::EnsureScriptEnvironment 
[d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 4475]
     nsDocShell::GetScriptGlobalObject 
[d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 2429]
     DocumentViewerImpl::Init 
[d:\builds\seamonkey\mozilla\content\base\src\nsDocumentViewer.cpp, line 574]
     nsDocShell::SetupNewViewer 
[d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 3040]
     nsWebShell::SetupNewViewer 
[d:\builds\seamonkey\mozilla\docshell\base\nsWebShell.cpp, line 361]
     nsDocShell::Embed 
[d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 2537]
     nsWebShell::Embed 
[d:\builds\seamonkey\mozilla\docshell\base\nsWebShell.cpp, line 385]
     nsDocShell::CreateContentViewer 
[d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 2817]
     nsDSURIContentListener::DoContent 
[d:\builds\seamonkey\mozilla\docshell\base\nsDSURIContentListener.cpp, line 
106]
     nsDocumentOpenInfo::DispatchContent 
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 374]
     nsDocumentOpenInfo::OnStartRequest 
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 243]
     nsStreamIOChannel::OnStartRequest 
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsInputStreamChannel.cpp, line 
460]
     nsOnStartRequestEvent::HandleEvent 
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStreamObserverProxy.cpp, line 
125]
     nsStreamObserverEvent::HandlePLEvent 
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStreamObserverProxy.cpp, line 
78]
     PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 
577]
     _md_EventReceiverProc 
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 1055]
     0x778b0c24  
(Assignee)

Comment 4

18 years ago
I find this hard to believe because a) I cannot reproduce it, and b) if this
were happening to other people I suspect there would be a lot more noise since
it's a pretty significant problem.  Can you still reproduce this with recent
builds, Patty?
(Reporter)

Comment 5

18 years ago
Joe, it works fine, no crash on the recent trunk build dated 
(2001-02-28-22-Mtrunk). 
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

18 years ago
Marking verified on windows 98 (2001-02-28-22-Mtrunk).
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.