Last Comment Bug 687568 - Extending the selection causes Scratchpad to scroll without making the selection visible
: Extending the selection causes Scratchpad to scroll without making the select...
Status: RESOLVED FIXED
[sourceeditor][orion]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: Firefox 10
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 697407
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-19 11:56 PDT by :Ehsan Akhgari
Modified: 2011-11-02 08:15 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description :Ehsan Akhgari 2011-09-19 11:56:35 PDT
STR:

1. Paste a relatively large JS file in Scratchpad.  Select the first three lines.
2. Click on the scrollbar to scroll one page down.
3. Shift+PgDn.  Scratchpad will scroll one page down, but the selected region is invisible.
Comment 1 Kevin Dangoor 2011-09-22 08:55:22 PDT
It looks like Orion is not selecting as much text as would be expected given the scroll position. I tried this in a Firefox text area and in TextMate. Those two behaved slightly differently, but the selection was visible in both, which is important.

Filed upstream: https://bugs.eclipse.org/bugs/show_bug.cgi?id=358615
Comment 2 Mihai Sucan [:msucan] 2011-10-14 10:14:44 PDT
This is now fixed upstream.
Comment 3 Mihai Sucan [:msucan] 2011-11-01 05:43:07 PDT
This is now fixed by bug 697407. QA will verify.
Comment 4 Alex Lakatos[:AlexLakatos] 2011-11-02 08:15:26 PDT
This is VERIFIED on Build identifier: Mozilla/5.0 (X11; Linux i686; rv:10.0a1) Gecko/20111102 Firefox/10.0a1

Note You need to log in before you can comment on or make changes to this bug.