Last Comment Bug 687573 - Orion does not maintain X offset when navigating vertically
: Orion does not maintain X offset when navigating vertically
Status: RESOLVED FIXED
[sourceeditor][orion]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 10
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 697407
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-19 12:01 PDT by :Ehsan Akhgari
Modified: 2011-11-02 09:02 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description :Ehsan Akhgari 2011-09-19 12:01:59 PDT
STR:

1. Paste this into scratch pad:

XPCOMUtils.defineLazyGetter(window, "gFindBar", function() {
  let XULNS = "http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul";
  let findbar = document.createElementNS(XULNS, "findbar");
  findbar.id = "FindToolbar";

  let browserBottomBox = document.getElementById("browser-bottombox");
  browserBottomBox.insertBefore(findbar, browserBottomBox.firstChild);

  // Force a style flush to ensure that our binding is attached.
  findbar.clientTop;
  findbar.browser = gBrowser;
  window.gFindBarInitialized = true;
  return findbar;
});

Make sure that the width of the scratchpad window is small enough for there to be a vertical scrollbar.
2. Put the caret at the end of the second line by scrolling the view horizontally.
3. Press down 4 times.  The caret should end up at the end of the "let browserBottomBox" line...
Comment 1 Kevin Dangoor 2011-09-22 09:10:00 PDT
I'm unable to reproduce this. In step 3, I always end up with the caret at the end of the "let browserBottomBox" line, no matter what the size of the window is.

In step 2, I'm scrolling horizontally and clicking at the end of the line (or pressing the keys to get to the end of the line).

Whichever way I get the caret to the end of the second line, the caret always ends up at the end of the 6th line.
Comment 2 Kevin Dangoor 2011-09-22 09:10:36 PDT
...err, ends up at the end of the 6th line when I press down 4 times.
Comment 3 :Ehsan Akhgari 2011-09-22 19:50:57 PDT
You should make sure that the scrollbar is moved towards the right.  FWIW, I saw this on Mac, but I doubt that it's platform specific.
Comment 4 Mihai Sucan [:msucan] 2011-10-07 12:40:42 PDT
This is a bug in Orion (Scratchpad just happens to use it). Marking this as a Mac bug, until we get to triage this and see if it's platform specific or not.

Ehsan, thanks for the report!
Comment 5 Mihai Sucan [:msucan] 2011-10-10 13:25:05 PDT
Confirmed on Linux, and it happens with the latest Orion upstream.

The caret location at step 3 depends on the scrollbar location at step 2.

Kevin: did you file a bug upstream for this?
Comment 6 Kevin Dangoor 2011-10-12 07:51:46 PDT
I was able to reproduce this bug just now (I ensured that I had both vertical and horizontal scrollbars... I don't remember if I had done that before).

Filed upstream:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=360672
Comment 7 Mihai Sucan [:msucan] 2011-10-26 07:41:21 PDT
This is now fixed upstream. Will be fixed for Mozilla once bug 697407 lands.
Comment 8 Mihai Sucan [:msucan] 2011-11-01 05:43:51 PDT
This is now fixed by bug 697407. QA will verify.
Comment 9 Alex Lakatos[:AlexLakatos] 2011-11-02 09:02:43 PDT
This is VERIFIED on Build identifier: Mozilla/5.0 (X11; Linux i686; rv:10.0a1) Gecko/20111102 Firefox/10.0a1

Note You need to log in before you can comment on or make changes to this bug.