SeaMonkey 2.3 draws all available CPU capacity and hangs for 1 - 2 min or more.

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: Rob, Unassigned)

Tracking

SeaMonkey 2.3 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:6.0.2) Gecko/20110902 Firefox/6.0.2 SeaMonkey/2.3.3
Build ID: 20110902180055

Steps to reproduce:

Opened 2 or more browser windows.  Random websites, though Facebook & iGoogle are most common.  Flash apps may be involved.

System: WinXP
CPU: 1.4 Ghz AMD Athlon (Single core)
Ram: 1.5 Gig


Actual results:

SeaMonkey browser GUI periodically 'hangs' for 1 - 2 minutes or more depending upon the number of windows/tabs that are open.  This appears to occur randomly, even if SeaMonkey is not the active/top window.  CPU usage usually jumps to 95%.  If this happens when the bookmarks menu is open, it (BM menu) remains on top of all active program windows except the Task Manager.

WinXP does NOT indicate that SeaMonkey is unresponsive.  
Other programs are slowed, but continue to respond - the OS does not lock up, just SeaMonkey.  
AVG Antivirus does not show any activity while this is happening.  (No sign of interference.)

A clean install of both SeaMonkey & FlashPlayer has not remedied the problem.


Expected results:

SeaMonkey should continue to respond at the best possible speed depending upon the circumstances.
Does this happen also in safe mode? (either "Help → Restart with Add-ons Disabled", or "seamonkey -safe-mode" (without the quotes, and starting from the installation directory) at the cmd.exe prompt) Or does it happen with a fresh profile? (see http://kb.mozillazine.org/Profile_Manager#Creating_a_new_profile )
(Reporter)

Comment 2

7 years ago
I tried running in safe mode, but the problem persisted.

I am in the process of creating a new profile now.
(Reporter)

Comment 3

7 years ago
So far so good.  The new profile appears to be trouble free and SM is now running significantly faster.

I'll watch it for another 24-48 hrs to make sure it is fully functional
If it happens in Safe Mode, then it is /a priori/ not due to an extension; but it could be due to interference from Mail & News. In your default profile (where you had the problem), did you have many mail servers, news servers and/or RSS feeds defined? Checking then less often might (but not necessarily) alleviate the problem. Or newsgroups with many saved read posts? Then setting a retention period might help. Also regular compacting of mail & news folders, see http://kb.mozillazine.org/Compacting_folders

Possible dupe? of bug 539194 (MailNews Core::Networking:NNTP) "MailNews reported as high CPU (100% for many seconds) caused by having news downloaded without bounds, i.e. no purging."
Whiteboard: DUPEME
(Reporter)

Comment 5

7 years ago
Two accounts on 1 server, that's all, & I've been in the habit of compacting the folders regularly.  I do not have any news server accounts.

Everything appears to be working properly now. 

Many thanks for the prompt assistance!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.