Korean IME: Candidate list can't be invoked after returning focus to Hangul character.

RESOLVED WORKSFORME

Status

()

Core
Internationalization
RESOLVED WORKSFORME
17 years ago
6 years ago

People

(Reporter: Wesley George, Assigned: Roy Yokoyama)

Tracking

({inputmethod, intl})

Trunk
Future
x86
Windows 98
inputmethod, intl
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
<summary>
Korean IME: Candidate list can't be invoked after returning focus to Hangul
character.

<repro environment>
build 02-13-04 + Win95-KOR, 
build 02-13-04 + Win98-JA + Korean Global IME

not repro with IE5.5-US + Win95-KOR or Win98-JA with Korean Global IME
 
<repro steps>
1. place cursor in an HTML edit field
2. switch to the Korean IME (or Korean Global IME for non-Korean Windows 9x, NT4 OS)
3. press left Alt key to turn on the IME
4. type "rksk"
   >>this generates 2 Hangul characters (and leaves focus on the second character)
5. press left Ctrl key to invoke the candidate list for the second Hangul character
6. press the left arrow key twice to move focus to the first Hangul character
7. press left Ctrl key to invoke the candidate list for the first Hangul character

<result>
Nothing happens

<expected result>
Candidate list should appear. 
Note: Each Hangul character should remain in composition mode until a Hanja
candidate is selected for it.

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
(Reporter)

Updated

17 years ago
Keywords: intl

Comment 1

17 years ago
Changed QA contact to ylong@netscape.com.
QA Contact: teruko → ylong
(Assignee)

Updated

17 years ago
Target Milestone: --- → mozilla1.0

Comment 2

17 years ago
This is lower priority for nsbeta1, and will probably better addresses before
final release.

Request target milestone after M0.9.1, and priority P3.
(Assignee)

Updated

17 years ago
Target Milestone: mozilla1.0 → Future
(Assignee)

Comment 3

17 years ago
ylong: I tried to reproduce this bug; but the steps are, I believe, in-correct
and I can't reproduce this bug.  (I have Win98CT with Korean GlobalIME.)

Here is what I did:
Follow up to Step4.
Step5: need to press RIGHT Ctrl key (instead of LEFT ctrl key) to invoke the
candidate list for the second Hangul character.
Step 6: I can't move focus to the first Hangul character character
The first Hangul character is already commited (and I think that's ok because
 that's how Korean IME works).  

What is a real bug here?  I noticed one thing that the candidate window 
covers your composition text; but that's not the issue here.

Can you verify this bug?  Thanks.

Comment 4

17 years ago
I got very similar result as you did - seems there are few steps in description 
that I can not follow(e.g. I can not turn on the IME by press left Alt key, I 
have to click on the IME window to switch to Kerean imput). It's hardly tell if 
I did the same steps that reporter did before.  I think Korean IME is different 
that Japanese or Chinese, I am not a good person for that.  We might wan to ask 
some other people's help for verify this. 

Comment 5

17 years ago
  At first I thought Roy was right in that the first Hangul syllable is
committed after the second Hangul syllable is converted to Hanja
so that it's normal that the candidate list doesn't show up when
the cursor is moved to the first Hangul syllable. 

  However, in both MS Word 2000 and MS IE 5.5 under MS Windows ME
(I don't have Win 98/95) Korean Global IME works the way ylong
described (except that Right-Ctrl key has to be used to  get
the candidate list instead of Left-Ctrl key). That is, even after the
second Hangul syllable is converted to Hanja, with the cursor(thin vertical
line) to the left of the first syllable (the first syllable is NOT put in
the inverse mode)  the candidate list shows up when Right-Ctrl key
is pressed. 

  So, this is definitely a bug on the part of Mozilla. (2001-07-19-03) 

Comment 6

14 years ago
has anyone with a Korean Windows retried this with a more recent Mozilla build?
QA Contact: amyy → i18n
Keywords: inputmethod
I cannot reproduce the original reported problem on WinXP and Win7. And also, the caret position problem which was described by jshin at comment 5 has been fixed by bug 226784.

-> WFM
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.