Scratchpad fails to paste the text content completely

RESOLVED DUPLICATE of bug 684862

Status

()

Firefox
Developer Tools
RESOLVED DUPLICATE of bug 684862
6 years ago
6 years ago

People

(Reporter: Away for a while, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sourceeditor][orion], URL)

(Reporter)

Description

6 years ago
Go to the page in the URL field, select all, and paste into scratchpad.

Comment 1

6 years ago
This appears to be the same problem as this upstream bug: https://bugs.eclipse.org/bugs/show_bug.cgi?id=355230

Comment 2

6 years ago
I'll also note that in both the case here and in the Orion bug cited in comment 1, the text being pasted in is not JavaScript or CSS (or plain text at all) so this is likely a lower priority problem because typical users would not encounter it.

Comment 3

6 years ago
If you cut-n-paste from an html page with code, that should work (and doesn't).  (note bug 685925).  That's pretty severe.
(Reporter)

Comment 4

6 years ago
Yes.  I think this is a general problem, and the actual textual content in the test cases that we have should not lure us into thinking that it's not important.

Comment 5

6 years ago
Valid point (as noted in bug 685925) that not all reasonable, pasteable code will be plaintext.

Updated

6 years ago
Whiteboard: [sourceeditor][orion]
This is now fixed upstream in Orion.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 684862
You need to log in before you can comment on or make changes to this bug.