Constrain the window size to a minimum width to avoid clipping our UI

RESOLVED DUPLICATE of bug 548777

Status

()

Core
Widget: Cocoa
RESOLVED DUPLICATE of bug 548777
6 years ago
6 years ago

People

(Reporter: jrmuizel, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Other applications like Chrome, Safari, Mail have a minimum width, we should do the same. This will avoid problems like: https://bugzilla.mozilla.org/attachment.cgi?id=561281
See bug 687880 comment #5, particularly the following paragraph:

Your second screenshot shows that, when the window reaches a minimum horizontal size, the vertical scrollbar gradually gets masked away as you continue to reduce its size (horizontally).  This is different from what happens when the window reaches a minimum vertical size -- in that case the horizontal scrollbar suddenly disappears (without ever being partially masked).

In Safari it's not possible to resize a window smaller than it's minimum size (vertical or horizontal).  That probably makes better sense than our current behavior.  But does our current behavior also happen on other platforms (like Windows or Linux)?  And would Safari's behavior also make sense there?
(Reporter)

Comment 2

6 years ago
On Linux we also, unlike other applications on that platform, let our window get very narrow, so I'd say adopting Safari's behaviour also makes sense there.
Duplicate of this bug: 686156
See bug 686156: I described further problems about this bug which makes some sites break.

This is especially harmful if one has a lot of add-ons buttons put on navigation toolbar.

Also: platform should be set to "All", I experience this issue both on Linux and Windows.
OS: Mac OS X → All
Hardware: x86 → All
Version: unspecified → Trunk
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 548777
IMO It's not a duplicate. Bug 548777 is about creating an arbitrary minimum window size, like 150x100 and it's definitely not about avoiding clipping of UI. It doesn't also address my problem reported in bug 686156.

In particular, this minimum window size should be changed based on how many items one has on their navigation bar. So definitely not small minimum static numbers.
You need to log in before you can comment on or make changes to this bug.