Last Comment Bug 688190 - Add various console warnings
: Add various console warnings
Status: RESOLVED FIXED
: dev-doc-complete
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla9
Assigned To: :Ms2ger
:
Mentors:
Depends on: 966385
Blocks: 683482 687422 687426 687579
  Show dependency treegraph
 
Reported: 2011-09-21 09:33 PDT by :Ms2ger
Modified: 2014-01-31 11:22 PST (History)
5 users (show)
Ms2ger: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Part a: Allow using nsIDocument::WarnOnceAbout for more cases (1.59 KB, patch)
2011-09-21 09:34 PDT, :Ms2ger
bzbarsky: review+
Details | Diff | Review
Part b: Add various warnings (6.39 KB, patch)
2011-09-21 09:35 PDT, :Ms2ger
bzbarsky: review+
Details | Diff | Review
Part b: Add various warnings (v2) (6.64 KB, patch)
2011-09-27 02:37 PDT, :Ms2ger
no flags Details | Diff | Review

Description :Ms2ger 2011-09-21 09:33:15 PDT

    
Comment 1 :Ms2ger 2011-09-21 09:34:24 PDT
Created attachment 561498 [details] [diff] [review]
Part a: Allow using nsIDocument::WarnOnceAbout for more cases
Comment 2 :Ms2ger 2011-09-21 09:35:01 PDT
Created attachment 561500 [details] [diff] [review]
Part b: Add various warnings
Comment 3 :Ms2ger 2011-09-25 11:38:51 PDT
Jonas, if you can't review this tomorrow, please reassign the r?.
Comment 4 Boris Zbarsky [:bz] 2011-09-26 22:14:49 PDT
Comment on attachment 561498 [details] [diff] [review]
Part a: Allow using nsIDocument::WarnOnceAbout for more cases

r=me
Comment 5 Boris Zbarsky [:bz] 2011-09-26 22:15:50 PDT
Comment on attachment 561500 [details] [diff] [review]
Part b: Add various warnings

r=me assuming these are in fact all deprecated..
Comment 7 Dão Gottwald [:dao] 2011-09-27 02:00:58 PDT
backed out since it didn't compile
Comment 8 :Ms2ger 2011-09-27 02:37:28 PDT
Created attachment 562692 [details] [diff] [review]
Part b: Add various warnings (v2)

Sorry about that, I was sure I fixed it.
Comment 9 Mounir Lamouri (:mounir) 2011-09-27 02:43:59 PDT
I did fix that locally too and ready to be pushed.
Comment 11 :Ms2ger 2011-09-27 12:01:38 PDT
Thanks a lot, guys!
Comment 12 j.j. 2012-02-22 13:54:29 PST
I added a "deprecated" warning for document.inputEncoding to the MDC doc.
Is there actually a plan/bug to drop support for it?

Note You need to log in before you can comment on or make changes to this bug.