Search icon missing or invisible on startup

RESOLVED WONTFIX

Status

Mozilla Labs Graveyard
Test Pilot
RESOLVED WONTFIX
7 years ago
2 years ago

People

(Reporter: Caspy7, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 561505 [details]
Search icon is missing

For most of the time I can remember Firefox 7 being in beta, the search icon is missing or invisible when I first start Firefox.
Google is my default search.  Only when I click on the space where the icon should be to get a list of engines and then select Google again does the icon actually display.
This has been occurring consistently for some time.
I'm on XP.
Including a screenshot as evidence.
Does that also happen with the default theme?
(Reporter)

Comment 2

7 years ago
(In reply to Henrik Skupin (:whimboo) from comment #1)
> Does that also happen with the default theme?

Yes.
(Reporter)

Comment 3

7 years ago
I've just determined that the culprit is the Test Pilot extension (current version 1.1.3).  
I disabled all addons and the aberrant behavior disappeared so I went through each addon.  I am able to disable all addons except Test Pilot and the problem is present, but when I disable Test Pilot the problem goes away.
Thanks Mark. Moving over to Test Pilot then for further investigation.
Component: Search → Test Pilot
Product: Firefox → Mozilla Labs
QA Contact: search → test-pilot
Mark, 

I can't reproduce this. Does it occur in a fresh profile? Could you do me a favor and create a new profile. Then run that profile with Fx7b6. TP 1.1.2 is installed by default. So, get the update to 1.1.3 for the extension via the addons manager.

Comment 6

7 years ago
Same issue here with TP 1.2 and FF 8.0: after initial startup, there is no Google icon in the Quick Search box. The issue was gone after deactivating TP and came back after reactivation of TP.

Tried to reproduce this with a clean profile; but for some reason the download of the TP add-on fails "because of a connection failure on addons.mozilla.org" with the error console mentioning "WARN addons.xpi: Download failed 404 NOT FOUND".
(Assignee)

Updated

2 years ago
Product: Mozilla Labs → Mozilla Labs Graveyard
decommissioned
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.