[traceback] DoesNotExist: RequestUser matching query does not exist.

RESOLVED WORKSFORME

Status

addons.mozilla.org Graveyard
Public Pages
P2
normal
RESOLVED WORKSFORME
7 years ago
2 years ago

People

(Reporter: krupa, Assigned: kumar)

Tracking

unspecified
6.2.9

Details

(URL)

(Reporter)

Description

7 years ago
steps to reproduce:
1. Load https://addons-dev.allizom.org/en-US/firefox/users/login?to=%2Fen-US%2Ffirefox%2F
2. Click on 'Login with BrowerID'
3. In the browserID popup, click on 'Add another email ID'
4. Add an email ID which is not associated with any AMO account


actual behavior:
500 Internal Server Error

Traceback (most recent call last):

 File "/data/www/addons-dev.allizom.org/zamboni/vendor/src/django/django/core/handlers/base.py", line 89, in get_response
   response = middleware_method(request)

 File "/data/www/addons-dev.allizom.org/zamboni/apps/access/middleware.py", line 20, in process_request
   amo_user = RequestUser.objects.get(pk=request.user.pk)

 File "/data/www/addons-dev.allizom.org/zamboni/vendor/src/django/django/db/models/manager.py", line 132, in get
   return self.get_query_set().get(*args, **kwargs)

 File "/data/www/addons-dev.allizom.org/zamboni/vendor/src/django/django/db/models/query.py", line 349, in get
   % self.model._meta.object_name)

DoesNotExist: RequestUser matching query does not exist.
We should fail gracefully I suppose.  Greg's new ajax-registration is an interesting idea, but for now let's just not traceback.
Assignee: nobody → kumar.mcmillan
Priority: -- → P4
Target Milestone: --- → 6.2.8
Priority: P4 → P2
Target Milestone: 6.2.8 → 6.2.9
I think this fixed itself.  When I go through the STR I see:

BrowserID login failed. Maybe you don't have an account under that email address? textStatus: error errorThrown: UNAUTHORIZED
https://skitch.com/e-kumar303/grdr6/user-login-add-ons-for-firefox

and there isn't a traceback in the log.  Did I miss a step?

This commit looks like it might have addressed the issue: https://github.com/mozilla/zamboni/commit/0fe3e56b
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.