Html edit mode for the mail composition window

RESOLVED DUPLICATE of bug 143593

Status

enhancement
RESOLVED DUPLICATE of bug 143593
8 years ago
8 years ago

People

(Reporter: peuktreuk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:9.0a1) Gecko/20110912 Firefox/9.0a1
Build ID: 20110912030829

Steps to reproduce:

Paolo Kaosmos has created a crutch for html edition in message composition,
but it's not a proper method, his addon is lacking an important aspect of that
tool.

Why is html edition important .. . anything can be edited in an html code,
like when html is pasted from the web, when tb 's toolbar is limited.

Why is html edition important 2 .. . if i receive spam i can know what
codes have been used to spam me & prevent them through user defined
filters. (it's helpful for filter creation). when you know that a color, a character,
& co, can be written differently in the html code.


Actual results:

Paolo Kaosmos edithtml tool doesn't respect encoding modification,
& there are different types of encoding at the code level, if people see
the same cyrillic characters for ex .. . or greek or chinese, etc etc .. .

But everything appears in unicode in his tool wheter i change or not
the encoding. it's improper, wrong & not every email servers support unicode.


Expected results:

It would be nice to implement a tb's default html editor for mail composition
Not even mentioning the fact that not every servers support all encodings .. .
There is HTML mode of the editor (message composition). Just enable it in Account Settings -> Composition & addressing -> Compose messages in HTML format.

I do not understand what exactly does not work for you.
(In reply to aceman from comment #2)
> There is HTML mode of the editor (message composition). Just enable it in
> Account Settings -> Composition & addressing -> Compose messages in HTML
> format.
> 
> I do not understand what exactly does not work for you.

Same here, you can edit in html in TB. What exactly are you missing ?
No. thunderbird does not provide a full html source code edition.

the addon i mentioned above allows that & is improperly conceived
since the source code always contains unicode & doesn't adapt itself to
encoding modifications, like in msoe.
Ah, you mean a full HTML source editor inside the composition window? Not just wysiwyg mode that produces HTML email?
exactly
If this is the extension you mention:
https://nic-nac-project.org/~kaosmos/edithtml-en.html
and it does what you wish, can't you contact the author so that he fixes the one nit you have with it (the encoding problem)?

For the spam problem, you can see the source HTML with Message -> View Source.
i warned the author, he's confused & doesn't seem to want to update his tool.
the critics i've made about missing functions of such source editor seem to be
too bothersome for him .. . he didn't reply back, result: let's keep thunderbird as a restrictive email client forever.

since you won't care to implement html code edition either.
I do not consider HTML edit important for one-time-use e-mail. I personally would not want to play with the source of a message. If Thunderbird already does not have HTML edit, adding it would not be trivial. And there must be clear "reward" for its implementation. If there already exists an extension for it, it may be waste of time.

But the implementation does not depend on me:)
You can request this feature, confirming.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Component: General → Composition
Ever confirmed: true
OS: Windows 7 → All
Product: Thunderbird → MailNews Core
QA Contact: general → composition
Hardware: x86 → All
1. an html source code is always more accurate than & allows tweaking what cannot be tweaked through formatting bars, you want 10 exs ? ok , my response: i won't give them to you cause your negativism is getting old.

2. i already told you that the author of that addon is confused & doesn't get the issue.

3. do what u want, u & devs, i don't care anymore, i'm always facing vain negativism when i try to make a program look cleaner like when i request emails
to be linkified or when i request standard & helpful accessibility options that
have been used since decades, people who used those options must be stupid like me, those millions of people all over the world .. . it's my way & their ways .. . let's change behaviours, mozilla has a new idea: REGRESSION & GETTING RID OF STANDARD OPTIONS.

I'm tired, i'm off to bed, tired of everything in this world.
Ok, I found this problem is already reported as bug 143593. Please vote there.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Summary: Html edition for the composition field → Html edit mode for the mail composition window
Duplicate of bug: 143593
You need to log in before you can comment on or make changes to this bug.