ignores color of followed links. Default followed link is too almost same as non-followed links.

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: johnhayre, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

3.43 MB, application/octet-stream
Details
(Reporter)

Description

7 years ago
Created attachment 561634 [details]
BrokenFirefoxVisitedLinks.rtf

User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.22) Gecko/20110902 Firefox/3.6.22 ( .NET CLR 3.5.30729; .NET4.0E)
Build ID: 20110902133716

Steps to reproduce:

Options/Content/color/visited links - change to red.


Actual results:

Not change UNLESS I uncheck "Allow pages to choose their own colors, instead of my selection above."
 
But if I DO uncheck it all the pages render poorly.  This was Marked Fixed but it is not.


Expected results:

It should cause visited links to be red.
I the above mentioned uncheck is done the attached file shows what Google comes up as.

Comment 1

7 years ago
I do not understand what the problem is. If you uncheck that option all color on the page are changed to the ones selected in that dialog (white, black, blue, red). What is bad about it?
However, do you see the problem in Firefox 6 or 9 ? Nothing will probably get fixed in Firefox 3.6.x...

Comment 2

7 years ago
> This was Marked Fixed but it is not.
where?
(Reporter)

Comment 3

7 years ago
It has exact same problem in 6.0.2.
Just look at this page.  The light blue and the darker blue (light purple?) are almost the same.  I would like to see a real difference.

Comment 4

7 years ago
I no not see any darker blur or light purple. In your screenshot the visited links are nice red (about the same as the 'o' and 'e' in the Google logo), unvisited links are light blue. Other text is black and the page background is white. Which text do you see as purple?

Comment 5

7 years ago
(In reply to johnhayre from comment #0)
> This was Marked Fixed but it is not.

What do you mean here? (repeating the question from comment 2)

Comment 6

7 years ago
If I understand it correct, your problem is as follows:

- Some pages have no or small color difference of unvisited/visited Links
- Therefore yo change the colors in the "Options" menu
- To apply this colors you have to uncheck "Allow pages to choose their own colors"

The selected text and background color apply also ands make pages readable but "ugly". That's expected behaviour, no bug. 

You can solve your problem with a userContent.css file.
Add styles like this:

a:link    { color: navy !important; background: white !important }
a:visited { color: lightblue !important }
a:hover   { background: gold !important }
a:active  { color: red !important }

You can also use the Stylish extension to add such styles.
https://addons.mozilla.org/firefox/addon/stylish/

(BTW, Firefox 3.6 is really out of date. You should download Firefox 7)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.