Last Comment Bug 688365 - [Skia] Enable 'new AA' mode
: [Skia] Enable 'new AA' mode
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla10
Assigned To: Matt Woodrow (:mattwoodrow) (PTO until 27 June)
:
Mentors:
Depends on:
Blocks: 687187
  Show dependency treegraph
 
Reported: 2011-09-21 22:25 PDT by Matt Woodrow (:mattwoodrow) (PTO until 27 June)
Modified: 2011-10-31 11:20 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Enable 'New AA' mode (918 bytes, patch)
2011-09-21 22:25 PDT, Matt Woodrow (:mattwoodrow) (PTO until 27 June)
jmuizelaar: review+
Details | Diff | Review

Description Matt Woodrow (:mattwoodrow) (PTO until 27 June) 2011-09-21 22:25:36 PDT
Created attachment 561656 [details] [diff] [review]
Enable 'New AA' mode

I haven't looked exactly at what this does, but we fail some tests quite badly without it.

Stroking a vertical line was giving us AA artifacts. Bizarre.
Comment 1 Jeff Muizelaar [:jrmuizel] 2011-09-21 23:11:06 PDT
(In reply to Matt Woodrow (:mattwoodrow) from comment #0)
> Created attachment 561656 [details] [diff] [review]
> Enable 'New AA' mode
> 
> I haven't looked exactly at what this does, but we fail some tests quite
> badly without it.
> 
> Stroking a vertical line was giving us AA artifacts. Bizarre.

Does Chrome have the same problem?
Comment 2 Matt Woodrow (:mattwoodrow) (PTO until 27 June) 2011-09-22 20:14:22 PDT
On windows, yes.

http://pastebin.mozilla.org/1334767 - Look for the small line of not-completely-green pixels
Comment 3 Jeff Muizelaar [:jrmuizel] 2011-09-23 12:49:21 PDT
Comment on attachment 561656 [details] [diff] [review]
Enable 'New AA' mode

This is fine for now
Comment 4 Jeff Muizelaar [:jrmuizel] 2011-09-23 12:54:22 PDT
We could also probably fix this by pixel aligning the line in the test case
Comment 5 Matt Woodrow (:mattwoodrow) (PTO until 27 June) 2011-10-30 17:51:11 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/7e59a560d237
Comment 6 Matt Brubeck (:mbrubeck) 2011-10-31 11:20:15 PDT
https://hg.mozilla.org/mozilla-central/rev/7e59a560d237

Note You need to log in before you can comment on or make changes to this bug.