Continuous periodic freezing / unfreezing after LockFile operation on places.sqlite-shm

RESOLVED DUPLICATE of bug 686025

Status

()

RESOLVED DUPLICATE of bug 686025
7 years ago
7 years ago

People

(Reporter: reqman, Unassigned)

Tracking

6 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 561788 [details]
firefoxcpuperiod.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.2) Gecko/20100101 Firefox/6.0.2
Build ID: 20110902133214

Steps to reproduce:

Everything worked fine with my Firefox on all my computers. All of them were sync'ed with firefox sync (including my mobile).

Then, on my Windows 7 Home Premium 64-bit desktop (Q9450 CPU, 4Gb of RAM, Asus P5KC motherboard Intel P35-based), I replaced the motherboard and the CPU. Obviously I reinstalled Windows from scratch and Firefox as well. From plugins, I installed only Adblock plus with the Easylist and malwaredomains lists. The same plugin (along with others) were installed previously on my desktop. I initiated a new sync and my bookmarks and everything obviously appeared ok. My new platform is now a Q9650 CPU, 8Gb RAM, Asus Rampage Extreme, Intel X48-based, which is not overclocked.


Actual results:

What happened is this:
1) I start browsing. Everything seems ok for some time.
2) At some point cpu utilization of the core ff is running on goes to 100% and stays there for 60". Firefox freezes but does not crash
3) After this 60" period passes, firefox becomes fully operational for 60"
4) A cycle starts with 60" of freeze, followed by 60" of operation, followed by 60" of freeze etc etc

The only way to stop this cycle is to exit firefox.

Tried the following:
* Running in safe mode: same issue
* Fully uninstalled ff, delete %appdata%\mozilla, re-installed ff sync and adblock plus. Same issue

Firefstrange freezes. These happened while I am trying to do an action, like fill in a form for example. Firefox does not freeze while it is idle. When this freeze takes place, it affects only firefox. Nothing else gets affected. Made a clean uninstall, re-installed with only adblock plus and enabled firefox sync. Issue happens also in safe mode.

It drives my crazy because both the motherboard and the cpu are better than the one I used to have. The system is not overclocked. All my other firefox installations work perfectly. I should add that I also tried checking with certain sqlite commands the integrity of all sqlite databases. All were ok. Additionally, I deleted this system from sync, completely uninstalled ff, deleted the relevant Application data subdirectories and made a fresh install, only with adblock plus and re-enabled sync. Same issue. Also tried using other memory DIMMs. Same thing again.


Expected results:

This freezing is not normal, does not happen in any of the other computers which use the same firefox sync account.
(Reporter)

Comment 1

7 years ago
Some more information: 

when bug appears, sysinternals process explorer shows that the dominating thread of CPU activity ios MOZCRT19.dll (see 2nd screenshot). At that time, the stack shows the following (please pardon me, I'm not a coder, trying my best here :) ):

mozsqlite3.dll!sqlite3_reset+0x2db1 mozsqlite3.dll!sqlite3_step+0xd9 xul.dll!?CanUseOpaqueSurface@Layer@layers@mozilla@@QAEHXZ+0x1d81 xul.dll!?CanUseOpaqueSurface@Layer@layers@mozilla@@QAEHXZ+0x1c58 xul.dll!?CanUseOpaqueSurface@Layer@layers@mozilla@@QAEHXZ+0x1bc6 xul.dll!NS_GetXPTCallStub_P+0xb59 xul.dll!?IsOriginalCharSkipped@gfxSkipCharsIterator@@QBEHPAH@Z+0x28f9a xul.dll!?GetEffectiveClipRect@Layer@layers@mozilla@@QAEPBUnsIntRect@@XZ+0x659 MOZCRT19.dll!_endthreadex+0x78 MOZCRT19.dll!_endthreadex+0x106 ntdll.dll!RtlInitializeExceptionChain+0x63 ntdll.dll!RtlInitializeExceptionChain+0x36
(Reporter)

Comment 2

7 years ago
Created attachment 561791 [details]
Threads at freeze

Plugins: 
* Shockwave Flash 
    Αρχείο: NPSWF32.dll
    Έκδοση: 10.3.183.10
    Shockwave Flash 10.3 r183

* Java(TM) Platform SE 6 U27

    Αρχείο: npjp2.dll
    Έκδοση: 6.0.270.7
    Next Generation Java Plug-in 1.6.0_27 for Mozilla browsers

* Java Deployment Toolkit 6.0.270.7

    Αρχείο: npdeployJava1.dll
    Έκδοση: 6.0.270.7
    NPRuntime Script Plug-in Library for Java(TM) Deploy

* NVIDIA 3D Vision

    Αρχείο: npnv3dv.dll
    Έκδοση: 7.17.12.8026
    NVIDIA 3D Vision plugin for Mozilla browsers

* NVIDIA 3D VISION

    Αρχείο: npnv3dvstreaming.dll
    Έκδοση: 7.17.12.8026
    NVIDIA 3D Vision Streaming plugin for Mozilla browsers
* Adobe Acrobat

    Αρχείο: nppdf32.dll
    Έκδοση: 9.4.5.236
    Adobe PDF Plug-In For Firefox and Netscape "9.4.5"

Additional information for my platform (in Greek, my apologies):

 Βασικά εφαρμογής
       Όνομα
       Firefox
       Έκδοση
       6.0.2
       User Agent
       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.2) Gecko/20100101 Firefox/6.0.2
       Κατάλογος προφίλ
         Άνοιγμα φακέλου
       Ενεργές πρόσθετες λειτουργίες
         about:plugins
       Build Configuration
         about:buildconfig
 Επεκτάσεις
       Όνομα
       Έκδοση
       Ενεργές
       ID
       Adblock Plus
       1.3.9
       true
       {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
       Java Console
       6.0.27
       false
       {CAFEEFAC-0016-0000-0027-ABCDEFFEDCBA}
 Τροποποιημένες προτιμήσεις
     Όνομα
     Τιμή
       accessibility.typeaheadfind
       true
       browser.places.smartBookmarksVersion
       2
       browser.startup.homepage_override.buildID
       20110902133214
       browser.startup.homepage_override.mstone
       rv:6.0.2
       browser.tabs.warnOnClose
       false
       extensions.lastAppVersion
       6.0.2
       network.cookie.prefsMigrated
       true
       places.history.expiration.transient_current_max_pages
       257672
       privacy.sanitize.migrateFx3Prefs
       true
       security.warn_viewing_mixed
       false
 Γραφικά
       Περιγραφή προσαρμογέα
       NVIDIA GeForce GTX 560 Ti
       ID Κατασκευαστή
       10de
       ID συσκευής
       1200
       RAM προσαρμογέα
       1024
       Οδηγοί προσαρμογέα
       nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
       Έκδοση οδηγού
       8.17.12.8026
       Ημερομηνία οδηγού
       8-3-2011
       Direct2D ενεργό
       true
       DirectWrite ενεργό
       true (6.1.7601.17514)
       Παράμετροι ClearType
       Οι παράμετροι ClearType δεν βρέθηκαν
       WebGL Renderer
       Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.686)
       Επιτάχυνση γραφικών GPU
       1/1 Direct3D 10
(Reporter)

Comment 3

7 years ago
Disabling graphics acceleration does not help.
(Reporter)

Comment 4

7 years ago
Using process monitor from Sysinternals, I noticed that the freeze start coincided with two lock/unlock operations, on file places.sqlite-shm:
* The first, was a LockFile operation (exclusive: false, offset: 123, length: 1, fail immediately:true) thas was succesful
* The second was an UnlockFileSingle operation (Offset: 123, Length: 1) that was also successful. 

Then, firefox does nothing for approximately 39". As far as cpu load is concerned, during these 39" cpu load rises to 100% with firefox being the dominating process. Specifically the mozsqlite thread. Things return to normal coinciding with an UnlockFileSingle operation for the same file and for the same offset:
* UnlockFileSingle (offset: 123, length: 1) success.

I made some more test runs. In all these periodic freezes, the system unfreeze coincided with an UnlockFileSingle operation to the same file places.sqlite-shm, same offset 123, same length 1.
(Reporter)

Updated

7 years ago
Summary: Continuous periodic freezing: 60" of freeze - 60" of normal operation → Continuous periodic freezing / unfreezing
(Reporter)

Updated

7 years ago
Summary: Continuous periodic freezing / unfreezing → Continuous periodic freezing / unfreezing after LockFile operation on places.sqlite-shm

Comment 5

7 years ago
Interesting. It seems you also tried to delete your profile, so places.sqlite should be empty. You also tried safe mode. Does it still happen in Firefox 7. Also, do you have an antivirus/antiadware/antimalware or any other sort of scanner program?
Note also a possibility sync may be involved bug author started this thread:https://support.mozilla.com/en-US/questions/880177#answer-253194 , and mentioned unable to try firefox 7 saying
> I'll try 7.0 when I get back, which will be in 1-2 weeks ...
Could bug686025 be partly related (that does also occur in safe mode though, and has a workaround)
I suspect it is, given the stack trace at the top.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 686025
(Reporter)

Comment 9

7 years ago
(In reply to aceman from comment #5)
> Interesting. It seems you also tried to delete your profile, so
> places.sqlite should be empty. You also tried safe mode. Does it still
> happen in Firefox 7. Also, do you have an antivirus/antiadware/antimalware
> or any other sort of scanner program?

- Have not tried FF 7, will be back in town on Wednesday.
- NOD32 AV (64-bit, not the Internet Security product)
- places.sqlite is essentially not empty after deleting the profile, because I have sync'ed. With a completely empty/new account, I was not able to replicate the issue.

(In reply to Christopher Blizzard (:blizzard) from comment #8)
> I suspect it is, given the stack trace at the top.
Most likely, it seems like we are talking about the same issue here. Will continue in the other bug report.

Comment 10

7 years ago
Can you confirm it is a duplicate? If you try Firefox Aurora 8 the problem should not be there.
(Reporter)

Comment 11

7 years ago
I am sorry, but after installing the places maintainance extension I am unable to reproduce the problem...
You need to log in before you can comment on or make changes to this bug.