Mozilla Postscript output is 5x to 20x size of IE output

RESOLVED INVALID

Status

()

RESOLVED INVALID
18 years ago
17 years ago

People

(Reporter: dclose, Assigned: dcone)

Tracking

Trunk
mozilla1.0.1
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: want for mozilla1.0.1, URL)

(Reporter)

Description

18 years ago
Printing to HP Postscript printer (8100 PS), either through spool or to file,
generates huge files which take excessively long to send to printer. With 0.7,
this URL produced nearly 4MB while IE generated only about 10KB. With nightly
build from Feb 13, difference is smaller but still outrageous.

Comment 1

18 years ago
Reporterdo you have a testcase we can use to test this?
(Assignee)

Comment 2

18 years ago
This may be due to an image output.  We are outputing ascii.. they may be doing 
some sort of binary output.. I am not sure.. just a guess
*** Bug 70639 has been marked as a duplicate of this bug. ***

Comment 4

18 years ago
Anyone able to reproduce?
Keywords: qawanted

Comment 5

18 years ago
Marking NEW based on duplication.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

18 years ago
Target Milestone: --- → Future
(Assignee)

Comment 6

18 years ago
*** Bug 80528 has been marked as a duplicate of this bug. ***

Comment 7

18 years ago
1. Can anyone please attach a PostScript output from IE, please ?
2. Is this a Win32 or cross-platform issue (unix) ?

Misc: 
- QA=roland.mainz@informatik.med.uni-giessen.de
- Setting target_milestone to mozilla1.0.1 - is this OK ?
Keywords: qawanted
QA Contact: sujay → Roland.Mainz
Whiteboard: want for mozilla1.0.1
Target Milestone: Future → mozilla1.0.1
(Assignee)

Comment 8

18 years ago
I think this is not a PostScript Issue as much as an ImageLib issue.  The images  
can be very large.. since we can use the native size of the original image. This 
Would make our output slower depending on the page.  The Postscript output can 
show exactly how large this can be.. and this issue is much worse on Postscript 
platforms such as Linux.

Comment 9

18 years ago
IE PostScript output was attached to bug 70639, marked as a duplicate of this one.
(Assignee)

Comment 10

18 years ago
I compared the file size using the HP colorlaser PS output.  The Mozilla file 
was basically a little over 2x the size.  I counted the number of images in both 
files.. and the mozilla file had 78 images and the explorer file had 40 images.  
Not sure what the extra images are from yet.. but I bet mozilla uses images for 
things that Expolorer does not.. and this may give us our file size difference.
(Assignee)

Comment 11

18 years ago
Mozilla has many more images than Explorer.. depending on the page.  The PS 
seems fine, just more images per page.  I will mark this as not a bug, since its 
just the way we lay out our HTML
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 12

18 years ago
Note that my experience is that files are much more than 2x, sometimes 20x. This
may be just the way Moz works, but it can be a serious problem. The result is
that shared printers take much longer for Moz print jobs, causing irritation
from other users. That could work against Mozilla.
(Assignee)

Comment 13

18 years ago
I agree, but the native layout module uses this method, which means printing 
uses this method.  I have not run across a 20x test case, but the test cases I 
used .. were 2x.  Again this was because of the images.  The PS was not any 
different that of Explorer.  I did want to run experiments and find out exactly 
which elements we use to layout are so big and I (or anyone who is interested) 
can test by printing one element at a time and finding out what elements use all 
the images. Then a bug can be filed.  Also.. native images can contribute to 
this since we no longer print images at the screen resolution but at the 
resolution of the native image.

Comment 14

18 years ago
*** Bug 93997 has been marked as a duplicate of this bug. ***

Comment 15

17 years ago
*** Bug 93344 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.