Closed Bug 688715 Opened 10 years ago Closed 10 years ago

Common mechanism delivering site previews of tabs in unloaded state.

Categories

(Firefox :: Tabbed Browser, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 497543

People

(Reporter: kulmegil, Unassigned)

Details

I noticed growing importance of tabs in unloaded state as they even managed to get an UI option in General options tab (fx 8.0). The Achilles feet of this useful feature are site previews and to be more specific handling those between sessions.

Currently keeping previews between sessions are exclusively used by Panorama (& cache mechanism) while all tabs view, ctrl+tab, windows jumplist, extensions, etc doesn't benefit and displays blanks.

A single site preview image can be used in all those places and with extensions, provided it meets some sensible minimum resolution and with some help of cropping & scaling if necessary.

I propose to create a common mechanism, probably some new service, that will be able to deliver those preview along with implementing support in all the places where tab previews are currently used. Possibility to override browser.cache.disk.enable for previews would be a very recommended option.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 497543
You need to log in before you can comment on or make changes to this bug.