If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

TB hangs after clicking "Anhang -> Datei(en) als Anhang einfügen" opening attachment dialog after a NAS device was disconnected

RESOLVED DUPLICATE of bug 442908

Status

Thunderbird
Mail Window Front End
--
critical
RESOLVED DUPLICATE of bug 442908
6 years ago
6 years ago

People

(Reporter: special, Unassigned)

Tracking

({hang})

6 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET4.0C)

Steps to reproduce:

Sent an Email and included a file from a NAS device as attachment. In a later session, the NAS device was disconnected and i tried to send another mail with attachment. I clicked on "Anhang -> Datei(en) als Anhang einfügen" again.


Actual results:

TB became unresponsive.


Expected results:

The Select a File window should have been opened.
In "prefs.js" the path to the NAS device was inserted ("mail.compose.attach.dis", ...).
Appearently TB tried to open this path and hanged.
This error condition should be trapped, i think.
How long do you waited ?
The timeout depends on windows and can be long (2min)
(Reporter)

Comment 2

6 years ago
(In reply to Matthias Versen (Matti) from comment #1)
> How long do you waited ?
The timeout depends on windows and can be long
> (2min)

Matthias,
tried it again. The Select a File Window was opened 105 seconds after clicking.
During this time TB was dead; no "Wait Please" or "Waiting for ..." appeared.
Keywords: hang
Matti, usul, this is a duplicate
Severity: normal → critical
Summary: TB hangs after clicking "Anhang -> Datei(en) als Anhang einfügen" → TB hangs after clicking "Anhang -> Datei(en) als Anhang einfügen" opening attachment dialog after a NAS device was disconnected
Whiteboard: [dupeme]

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Whiteboard: [dupeme]
Duplicate of bug: 442908
You need to log in before you can comment on or make changes to this bug.