Last Comment Bug 689036 - Clean up extensions/pref/ makefiles + makefiles.sh
: Clean up extensions/pref/ makefiles + makefiles.sh
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: -- minor (vote)
: mozilla10
Assigned To: Ed Morley [:emorley]
:
: Gregory Szorc [:gps]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-25 09:22 PDT by Ed Morley [:emorley]
Modified: 2011-09-29 01:23 PDT (History)
3 users (show)
emorley: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (3.92 KB, patch)
2011-09-25 09:24 PDT, Ed Morley [:emorley]
khuey: review+
Details | Diff | Splinter Review

Description Ed Morley [:emorley] 2011-09-25 09:22:55 PDT
extensions/pref/makefiles.sh:
- extensions/pref/autoconfig/resources/Makefile no longer exists
- extensions/pref/system-pref/src/Makefile + extensions/pref/system-pref/src/gconf/Makefile are missing from the list

extensions/pref/system-pref/Makefile.in:
- can be removed since only includes src/ , which can be included one level higher up

extensions/pref/system-pref/src/Makefile.in:
- uses several ifdef MOZ_ENABLE_GTK2, however system-pref/* only gets included when |ifdef MOZ_ENABLE_GTK2| anyway, so no need to check again
Comment 1 Ed Morley [:emorley] 2011-09-25 09:24:57 PDT
Created attachment 562305 [details] [diff] [review]
Patch v1
Comment 3 Michael Wu [:mwu] 2011-09-29 01:23:09 PDT
https://hg.mozilla.org/mozilla-central/rev/76e376b31870

Note You need to log in before you can comment on or make changes to this bug.