With bookmarks toolbar shown, bookmarking a page fills only half of the star background

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

({regression})

8 Branch
x86
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(firefox7-, firefox8-)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 562333 [details]
screenshot

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:8.0a2) Gecko/20110924 Firefox/8.0a2 ID:20110924042014

When I bookmark a page via Cmd+D with my Aurora build the background of the star in the location bar gets only filled half. See the attached screenshot. It's always reproducible for me. Tested with a fresh profile. This is a regression between Firefox 6.0.2 and builds of Firefox 7.0. I haven't checked for a narrower regression range.

Steps:
1. Create a fresh profile and start Firefox
2. Enable the Bookmarks Toolbar
3. Press Cmd+D to bookmark the page
4. If the star is completely filled - press ESC and repeat step 3

Not sure how this obviously visible regression in primary ui plays into our schedule for Firefox 7. Probably not a blocker but assigning Asa and Christian for feedback.
Attachment #562333 - Flags: approval-mozilla-beta?
Attachment #562333 - Flags: approval-mozilla-aurora?
(Reporter)

Comment 1

6 years ago
Meant to set the tracking flags...
tracking-firefox7: --- → ?
tracking-firefox8: --- → ?
(Reporter)

Updated

6 years ago
Attachment #562333 - Flags: approval-mozilla-beta?
Attachment #562333 - Flags: approval-mozilla-aurora?

Comment 2

6 years ago
Release drivers don't feel the need to track this and it doesn't seem to reproduce 100% of the time.
tracking-firefox7: ? → -
tracking-firefox8: ? → -

Comment 3

6 years ago
Created attachment 562675 [details]
screenshot

WFM on Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:8.0a2) Gecko/20110926 Firefox/8.0a2

The whole star is filled and the same behavior is applied on:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:7.0) Gecko/20100101 Firefox/7.0 RC and
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0a1) Gecko/20110925 Firefox/9.0a1
(Reporter)

Comment 4

6 years ago
Which steps have you performed exactly?

Comment 5

6 years ago
Hi Henrik.
I have followed exactly your steps: fresh profile, bookmarks toolbar on and I've repeated step 3 for aprox 10 times. The star gets filled every time. Exactly the same happens on Firefox 6.0.2.
I tried bookmarking the about: page and also romanian and international sites and it's working every time though I don't think that the sites could be the problem.
(Reporter)

Comment 6

6 years ago
Have you also pressed ESC in-between the individual step 3 actions? That's essential for this bug report.

Comment 7

6 years ago
Yes I did. I've pressed cmd+d and when the doorhanger appeared, I pressed  ESC to close it and repeat the steps.
looks like a graphics bmp filling issue more than something related to bookmarks or js...
(Reporter)

Comment 9

6 years ago
Disabling h/w acceleration solves the problem with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:8.0) Gecko/20100101 Firefox/8.0. Moving over to graphics.
Component: Bookmarks & History → Graphics
Product: Firefox → Core
QA Contact: bookmarks → thebes
Version: 5 Branch → 8 Branch
I couldn't reproduce this issue after trying several times, with different websites, on the Nightly from the 24th and 25th of September 2011, when the bug was logged.

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0a1) Gecko/20110924 Firefox/9.0a1
Build ID: 20110924030858

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0a1) Gecko/20110925 Firefox/9.0a1
Build ID: 20110925030856

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.