[traceback] ServerError: error 10 from memcached_add: SERVER ERROR at /en-US/firefox/i/user/37347/

RESOLVED DUPLICATE of bug 682801

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED DUPLICATE of bug 682801
7 years ago
3 years ago

People

(Reporter: krupa, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

7 years ago
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:7.0) Gecko/20100101 Firefox/7.0

steps to reproduce:
1. Load https://addons-dev.allizom.org/en-US/firefox/i/user/37347/

actual behavior:
Traceback! I suspect that the traceback is caused by the many number of add-ons and reviews associated with this user.

I don't see addons-dev listed in arecibo and something is busted with my gmail account. So, I don't see the traceback. I will attach the traceback asap.
(Reporter)

Comment 1

7 years ago
Traceback (most recent call last):

 File "/data/www/addons-dev.allizom.org/zamboni/vendor/src/django/django/core/handlers/base.py", line 111, in get_response
   response = callback(request, *callback_args, **callback_kwargs)

 File "/data/www/addons-dev.allizom.org/zamboni/apps/users/views.py", line 477, in impala_profile
   return jingo.render(request, 'users/impala/profile.html', data)

 File "/data/www/addons-dev.allizom.org/zamboni/vendor/src/jingo/jingo/__init__.py", line 79, in render
   rendered = render_to_string(request, template, context)

 File "/data/www/addons-dev.allizom.org/zamboni/vendor/src/jingo/jingo/__init__.py", line 97, in render_to_string
   return template.render(**get_context())

 File "/usr/lib64/python2.6/site-packages/jinja2/environment.py", line 891, in render
   return self.environment.handle_exception(exc_info, True)

 File "/data/www/addons-dev.allizom.org/zamboni/apps/users/templates/users/impala/profile.html", line 1, in top-level template code
   {% extends "impala/base.html" %}

 File "/data/www/addons-dev.allizom.org/zamboni/templates/impala/base.html", line 164, in top-level template code
   {% block main_content %}

 File "/data/www/addons-dev.allizom.org/zamboni/templates/impala/base.html", line 169, in block "main_content"
   {% block content %}{% endblock %}

 File "/data/www/addons-dev.allizom.org/zamboni/apps/users/templates/users/impala/profile.html", line 34, in block "content"
   {% include "users/impala/vcard.html" %}

 File "/data/www/addons-dev.allizom.org/zamboni/apps/users/templates/users/impala/vcard.html", line 41, in top-level template code
   {% trans num=profile.addons_listed|length %}

 File "/data/www/addons-dev.allizom.org/zamboni/vendor/src/django/django/db/models/query.py", line 82, in __len__
   self._result_cache = list(self.iterator())

 File "/data/www/addons-dev.allizom.org/zamboni/vendor/src/django-cache-machine/caching/base.py", line 108, in __iter__
   self.cache_objects(to_cache)

 File "/data/www/addons-dev.allizom.org/zamboni/vendor/src/django-cache-machine/caching/base.py", line 115, in cache_objects
   cache.add(query_key, objects, timeout=self.timeout)

 File "/data/www/addons-dev.allizom.org/zamboni/vendor/src/django/django/core/cache/backends/memcached.py", line 54, in add
   return self._cache.add(key, value, self._get_memcache_timeout(timeout))

ServerError: error 10 from memcached_add: SERVER ERROR
Summary: traceback on loading /en-US/firefox/i/user/37347/ → [traceback] ServerError: error 10 from memcached_add: SERVER ERROR at /en-US/firefox/i/user/37347/
(Reporter)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 682801
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.