Going to mozilla.org from Safari on Mac PPC serves up Firefox 4, then Firefox 7 beta, none of which work on the PPC Macs

RESOLVED DUPLICATE of bug 766606

Status

RESOLVED DUPLICATE of bug 766606
7 years ago
6 years ago

People

(Reporter: limi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

Attached are screenshots from the experience, but the short version is:

1. Attempting to install Firefox on my parents' computer, an older PowerBook.
2. First attempt to go to mozilla.com results in a page with no links or images (Step 1.png), using Safari 3.1.2 (Step 2.png)
3. By searching, I found a page with a download link (Step 3.png) that tells me that Firefox 4 is available
4. Clicking the download link serves up Firefox 7 beta (!), (Step 4.png)
5. The page being shown after clicking download is also without images (Step 5.png)

Not sure how important this is, but it would be great if we didn't show the link to Firefox newer than 3.6 since it isn't supported for PPC. Or we could point to the community-maintained TenFourFox build.

Comment 6

7 years ago
Thanks Limi.

James/Steven/Anthony...what do you think? Are we missing a redirect rule?
(Assignee)

Updated

7 years ago
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
(Assignee)

Updated

6 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 766606
You need to log in before you can comment on or make changes to this bug.