Closed Bug 689110 Opened 9 years ago Closed 7 years ago

[Skia] Fix shadow drawing in Skia

Categories

(Core :: Graphics, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 976184

People

(Reporter: mattwoodrow, Assigned: gw280)

References

Details

Attachments

(2 files)

The provided code for drawing shadows in Skia uses the default mask of the draw operation for blurring, instead of the alpha channel of the source.

We should fix this, and then use the provided code instead of duplicating it.
Attachment #562374 - Flags: review?(jmuizelaar)
Attachment #562375 - Flags: review?(jmuizelaar)
Comment on attachment 562374 [details] [diff] [review]
Draw the source into the mask for blurring

I have no idea if this is correct. I'd rather this behaviour change be upstreamed before we take advantage of it, however, I could be convinced otherwise.
This should be a fairly decent performance improvement for us, and it's much easier to read.

That said, I somewhat agree with your stance on this.

Is it worth submitting the first part of this to the chrome bug you filed and/or filing a Skia bug for this?
George: I think we still want this, our current shadow code is pretty ugly.
Milan, please land or invalidate this.
Assignee: nobody → milan
Attachment #562374 - Flags: review?(jmuizelaar) → review?(gwright)
Attachment #562375 - Flags: review?(jmuizelaar) → review?(gwright)
Let's compare this to the current Skia version, review and ask upstream as well.
Assignee: milan → gwright
Comment on attachment 562375 [details] [diff] [review]
Use SkBlurDrawLooper since it's now correct

Review of attachment 562375 [details] [diff] [review]:
-----------------------------------------------------------------

I think the patch in bug 976184 is the correct fix here.
Attachment #562375 - Flags: review?(gwright) → review-
Attachment #562374 - Flags: review?(gwright)
Attachment #562375 - Flags: review-
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 976184
You need to log in before you can comment on or make changes to this bug.