Explore improvements of displaying mail server errors when sending (currently modal alert): Should this be non-modal/inline/bundle multiple errors?



Mail Window Front End
7 years ago
4 years ago


(Reporter: Sami Lappalainen / ZAS DATA, Unassigned)


Windows 7

Firefox Tracking Flags

(Not tracked)




7 years ago
User Agent: Opera/9.80 (Windows NT 6.1; U; en) Presto/2.9.168 Version/11.51

Steps to reproduce:

Tried to send mail to 182 colleagues.

Actual results:

I got stuck 17 times times on non-existent domains - after a tedious manual search and remove of the SINGLE address at a time, I get to wait as it checks also the domains validated last time AGAIN.

Expected results:

The mail should have been sent to valid domains, then AFTER it's sent I should get a list of non-valid domains - as a popup or rather as a new message in my inbox.

Yes, I know this is borderline feature request, but it's very daunting to do manual searches (at least give us find, or click-to-remove on the message!) on long lists.

This shouldn't be an issue spam-wise, since non-existent addresses still get delivered if they are in working domains.
Do you had a invalid email address syntax or a non-existing domain ?
TB can only warn/reject if the email address syntax is incorrect.
The cc/bcc addresses are just given to the SMTP server and the SMTP seem to have rejected the mail afterwards and you get a reject mail with the reason.

Your bug is at the wrong place because you have to file it for the used SMTP server software.
Last Resolved: 7 years ago
Resolution: --- → INVALID

Comment 2

7 years ago
non-existing domain

--> I don't get any reject mail, I wish I did.

Instead, there's a very anti-useful popup box. 17 popup boxes for 17 wrong addresses. One at a time. A pain to send mail.

It would help so much if non-existings domains would work like non-existing addresses in valid domains. At the moment they do not. (of course this should be a selectable option, so that people who typo a lot could still get their popup box for the single message)

I don't believe this has anything to do with SMTP, since it happens on both of the two different servers we use and we didn't have this problem with Outlook or TB2 with the same servers. It appeared it TB3 and seems to persist.

Please re-evaluate.
Resolution: INVALID → ---
What is the exact error message including the title for that popup ?
TB doesn't know anything about non existing domains if the format of the email address is correct.
The behaviour seen in TB in reaction to sending to invalid recipient domain depends on the SMTP server:
Some servers, like gmail.com, do not return an immediate error but send back a failure email message instead.
Other servers, like gmx.de, return an immediate error upon sending and that error is displayed by TB in a modal alert:

An error occurred while sending mail. The mail server responded:  Requested action not taken: mailbox unavailable
invalid DNS A/AAAA resource record. Please check the message recipient test@asdfinvalid.com and try again.

For multiple wrong recipients, I only got one error message, but I suppose that depends on the SMTP server behaviour again.

So the possibilities to tweak TB here are very limited, e.g.
- make modal alert non-modal/inline
- collect multiple errors into single alert/inline error display

So this is just a starting point for further analysis.
There might be room for improvement here, but I'd rather invest time into more relevant bugs/RFEs.
Severity: normal → enhancement
Summary: sending breaks if non-existent domains on recipient list → Explore improvements of displaying mail server errors when sending (currently modal alert): Should this be non-modal/inline/bundle multiple errors?

Comment 5

4 years ago
Dear Sirs,

Thomas, you're right, only one message is displayed for multiple false addresses because sending BREAKS to the first false address. So the message does not get delivered AT ALL even to good addresses.

This is very tedious, as the user has to manually find the problematic address (difficult, since no search option is provided in the address field) and remove it. However, the user can't know if there are other faulty addresses, so he has to repeat the cycle (and it takes a while as all the good addresses up until the faulty address are AGAIN DNS-checked) over and over again until all faulty addresses are removed and the message can be sent.

For us, this lead to the creation of our own program, that sends always on the first time and then summarizes the errors to a list so that the user can take action accordingly. But the message needs to be sent only ONE time vs. maybe 20 or 30 with Thunderbird with our material.

I agree that this problem doesn't touch everybody. However, for people sending out distribution mails this is quite severe. This is often the case with associations - especially the small ones that can't afford a 'real' mailing list. This is also our case, but we are one of the more wealthy ones so we were able to pay for our own tool. I think it would be in the spirit of the Mozilla project to do this for everybody, and benefit especially the small, poor non-profits.
You need to log in before you can comment on or make changes to this bug.