Update the fidesfit-client tests to new stable version

RESOLVED WONTFIX

Status

Mozilla QA
Mozmill Tests
--
minor
RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: Marc-Aurèle DARCHE, Assigned: Marc-Aurèle DARCHE)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

6 years ago
At the moment the tests for the fidesfit-client extension in the mozmill-tests repository are using the fidesfit-client version 0.39.0 while there is now a much more recent version.

Moreover this new version uses the assertions module.
(Assignee)

Updated

6 years ago
Blocks: 568958
(Assignee)

Updated

6 years ago
Depends on: 674013
Marc, what are your plans to upgrade your tests to the most recent version of Fidesfit?
Assignee: nobody → mozdev
Status: UNCONFIRMED → NEW
Component: Mozmill Automation → Mozmill Tests
Ever confirmed: true
QA Contact: mozmill-automation → mozmill-tests
(Assignee)

Comment 2

6 years ago
I would like to commit the new tests and the new version of the fidesfit-client, even if I'm working on the Jetpack version at the same time. But to commit those new tests and new version I'm really blocked by bug 674013: without bug 674013 fixed only a few tests are passing because providing initial login information is necessary for the new version of fidesfit-client.
Thanks Marc. I missed that bug. I have now commented on it. Hopefully we can have a fix soon.
Support for fidesfit client has been dropped. So it's a wontfix.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.