All users were logged out of Bugzilla on October 13th, 2018

Browser crashes after entering stock quotes in Stocks panel's textfield and hitting ENTER

VERIFIED FIXED in mozilla0.9.1

Status

P1
critical
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: shrir, Assigned: matt)

Tracking

Trunk
mozilla0.9.1
x86
All

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Seen on all platforms, trunk builds

Steps:
Launch sidebar stocks panel
Enter a stock symbol in the textfield and hit ENTER or press 'Quote' button
Enter another symbol and hit ENTER ot press 'quote' button
On windows, this definitely crashes after the second attempt. On mac and linux, 
it crashes too but not with a definite number of attemps.

Stack trace coming....
(Reporter)

Comment 1

18 years ago
trace: 

  
   nsCOMPtr_base::assign_with_AddRef 
                                          
[d:\builds\seamonkey\mozilla\xpcom\base\nsCOMPtr.cpp, line 59]
     
   nsDocShell::PersistLayoutHistoryState 
                                          
[d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 4170]
     
   nsDocShell::Embed 
                                          
[d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 2532]
     
   nsWebShell::Embed 
                                          
[d:\builds\seamonkey\mozilla\docshell\base\nsWebShell.cpp, line 385]
     
   nsDocShell::CreateContentViewer 
                                          
[d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 2811]
     
   nsDSURIContentListener::DoContent 
                                          
[d:\builds\seamonkey\mozilla\docshell\base\nsDSURIContentListener.cpp, line 104]
     
   nsDocumentOpenInfo::DispatchContent 
                                          
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 370]
     
   nsDocumentOpenInfo::OnStartRequest 
                                          
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 242]
     
   nsHTTPFinalListener::OnStartRequest 
                                          
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHTTPResponseListener.cp
p, line 1142]
     
   nsHTTPCacheListener::OnStartRequest 
                                          
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHTTPResponseListener.cp
p, line 152]
     
   AsyncReadStreamAdaptor::OnStartRequest 
                                          
[d:\builds\seamonkey\mozilla\netwerk\cache\memcache\nsMemCacheChannel.cpp, line 
136]
     
   nsOnStartRequestEvent0::HandleEvent 
                                          
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line 
213]
     
   nsStreamListenerEvent0::HandlePLEvent 
                                          
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line 
107]
     
   PL_HandleEvent 
                                          
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 577]
     
   _md_EventReceiverProc 
                                          
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 1055]

Comment 2

18 years ago
I just tried it on my windows box using 2/15 trunk...I can't reproduce it..

Comment 3

18 years ago
This looks like a dupe of bug 68868 what do you guys think

Comment 4

18 years ago
Marking nsbeta1+, p1, mozilla0.9.1
Keywords: nsbeta1+
Priority: -- → P1
Target Milestone: --- → mozilla0.9.1
(Assignee)

Comment 5

18 years ago
fixed
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 6

18 years ago
verified in 4/25 build.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.