Show 'Write a review' link to only users who have purchased the paid add-on

VERIFIED FIXED in 6.2.6

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: krupa, Assigned: cvan)

Tracking

unspecified
6.2.6

Details

(URL)

(Reporter)

Description

7 years ago
steps to reproduce:
1. Make sure you haven't purchased https://addons-dev.allizom.org/en-US/firefox/addon/assistant
2. Log in to AMO and load https://addons-dev.allizom.org/en-US/firefox/addon/assistant


expected behavior:
Link to write a review is not shown to users who haven't purchased the add-on.

actual behavior:
Link is listed.
This is talking about the "This add-on has not yet been reviewed. Be the first! " text.  The "Write a review" button on the right is not there, as expected.

Also should double check the "See all reviews" page for a purchased add-on since it has a button too.
(Assignee)

Updated

7 years ago
Assignee: nobody → cwiemeersch
(Assignee)

Comment 2

7 years ago
https://github.com/jbalogh/zamboni/commit/6ab76e5
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

7 years ago
verified fixed at https://addons-dev.allizom.org/en-US/firefox/addon/assistant/reviews/

https://addons-dev.allizom.org/en-US/firefox/addon/assistant

I also verified that you can add a review once you have made a purchase.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.