Fennec makes you select your choice twice in select boxes

RESOLVED WORKSFORME

Status

Fennec Graveyard
General
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: gerv, Unassigned)

Tracking

Firefox 9
Other
Android

Details

(Reporter)

Description

6 years ago
Asus tab, 9.0 nightly.

If you click on an option in a non-dropdown single select, such as the version selector on the bug filing page, it selects that option but then pops up an overlay and makes you select it again. The popup behaviour is fine for dropdown list boxes but not for the ones with a size > 1.

Gerv

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 685197
(Reporter)

Comment 2

6 years ago
These aren't the same bug. There are ways you could fix 685197 which would not fix this. They are related, but not the same.

Gerv
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Well, the patch that I'll attach in bug 685197 will fix this.
(Reporter)

Comment 4

6 years ago
How will the behaviour change?

Gerv
Ah, sorry, this is indeed not a duplicate. Actually, it might be the opposite of bug 685197.
I guess this might be bug 650719.
(Reporter)

Comment 7

6 years ago
This is now sort of fixed, because when you click the box, it does _not_ make a new choice. If we are going to be consistent and do the overlay UI each time, then this is the right behaviour. If we want to allow people to select options directly, then obviously it's not. Still, the inconsistency is gone in 10.0a1, so resolving the bug.

Gerv
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.