Build process in broken in nsDOMClassInfo.cpp

RESOLVED DUPLICATE of bug 689301

Status

()

RESOLVED DUPLICATE of bug 689301
7 years ago
7 years ago

People

(Reporter: fredbezies, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
This morning, when I tried to build trunk, it happened to be broken while processing nsDOMClassInfo.cpp

Here is the .mozconfig I used (which worked yesterday), before upgrading my source code :

#
# See http://www.mozilla.org/build/ for build instructions.
#

export AUTOCONF=autoconf-2.13

mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../objdir-fx
mk_add_options MOZ_MAKE_FLAGS=-j4

# Options for ‘configure’ (same as command-line options).
ac_add_options --enable-application=browser
ac_add_options --enable-optimize
ac_add_options --disable-debug
ac_add_options --disable-tests
ac_add_options --disable-crashreporter
ac_add_options --with-ccache
ac_add_options --disable-installer
ac_add_options --disable-warnings-as-errors

Enabling / disabling --with-ccache don't change anything.

Here is the log of crash :

In the directory  /home/fred/logs/fox/objdir-fx/dom/base
The following command failed to execute properly:
c++ -o nsDOMClassInfo.o -c -I../../dist/stl_wrappers -I../../dist/system_wrappers -include /home/fred/logs/fox/src/config/gcc_hidden.h -D_IMPL_NS_LAYOUT -DMOZ_JSDEBUGGER -DMOZILLA_INTERNAL_API -D_IMPL_NS_COM -DEXPORT_XPT_API -DEXPORT_XPTC_API -D_IMPL_NS_GFX -D_IMPL_NS_WIDGET -DIMPL_XREAPI -DIMPL_NS_NET -DIMPL_THEBES -DSTATIC_EXPORTABLE_JS_API -DOSTYPE="Linux3" -DOSARCH=Linux -DEXCLUDE_SKIA_DEPENDENCIES -DOS_LINUX=1 -DOS_POSIX=1 -I/home/fred/logs/fox/src/dom/base -I/home/fred/logs/fox/src/dom/src/events -I/home/fred/logs/fox/src/dom/src/storage -I/home/fred/logs/fox/src/dom/src/offline -I/home/fred/logs/fox/src/dom/src/geolocation -I/home/fred/logs/fox/src/dom/src/notification -I/home/fred/logs/fox/src/dom/workers -I/home/fred/logs/fox/src/content/xbl/src -I/home/fred/logs/fox/src/content/xul/document/src -I/home/fred/logs/fox/src/content/events/src -I/home/fred/logs/fox/src/content/base/src -I/home/fred/logs/fox/src/content/html/content/src -I/home/fred/logs/fox/src/content/html/document/src -I/home/fred/logs/fox/src/content/svg/content/src -I/home/fred/logs/fox/src/layout/generic -I/home/fred/logs/fox/src/layout/style -I/home/fred/logs/fox/src/layout/xul/base/src -I/home/fred/logs/fox/src/layout/xul/base/src/tree/src -I/home/fred/logs/fox/src/ipc/chromium/src -I/home/fred/logs/fox/src/ipc/glue -I../../ipc/ipdl/_ipdlheaders -I/home/fred/logs/fox/src/dom/base/../../js/src/xpconnect/src -I/home/fred/logs/fox/src/dom/base/../../js/src/xpconnect/wrappers -I/home/fred/logs/fox/src/xpcom/ds -I/home/fred/logs/fox/src/dom/base -I. -I../../dist/include -I../../dist/include/nsprpub -I/home/fred/logs/fox/objdir-fx/dist/include/nspr -I/home/fred/logs/fox/objdir-fx/dist/include/nss -fPIC -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -Wno-long-long -fno-strict-aliasing -std=gnu++0x -pthread -ffunction-sections -fdata-sections -pipe -DNDEBUG -DTRIMMED -g -Os -freorder-blocks -fomit-frame-pointer -pthread -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng14 -I/usr/include/gtk-unix-print-2.0 -DMOZILLA_CLIENT -include ../../mozilla-config.h -MD -MF .deps/nsDOMClassInfo.pp /home/fred/logs/fox/src/dom/base/nsDOMClassInfo.cpp
make[6]: *** [nsDOMClassInfo.o] Erreur 1
make[6]: *** Attente des tâches non terminées....
make[5]: *** [libs] Erreur 2
make[4]: *** [libs_tier_platform] Erreur 2
make[3]: *** [tier_platform] Erreur 2
make[2]: *** [default] Erreur 2
make[1]: *** [realbuild] Erreur 2
make: *** [build] Erreur 2
Did the compiler actually *crash*, or did it just error out? Also, there should be an error earlier in the log; it might be a while back due to the -j4.
(Reporter)

Comment 2

7 years ago
Building process crash, not a compiler one. Will try disabling -j4 and report asap.
An actual error message would help a lot here ...
(Reporter)

Comment 4

7 years ago
Building process with deactived -j4 option is on its way. Please, just wait a few minutes.
(Reporter)

Comment 5

7 years ago
Got a more complete log. Attach it to keep this bug report readable.
(Reporter)

Comment 6

7 years ago
Created attachment 562720 [details]
Error log. Sorry, there is some french speaking error message in it :(
Thanks for the more verbose log.  This is Bug 689301.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 689301
You need to log in before you can comment on or make changes to this bug.