Alignment in message thread pane is off

RESOLVED FIXED in Thunderbird 10.0

Status

Thunderbird
Theme
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: andreasn, Assigned: Paenglab)

Tracking

(Blocks: 1 bug)

Trunk
Thunderbird 10.0
x86
All
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 4 obsolete attachments)

(Reporter)

Description

6 years ago
Created attachment 562735 [details]
mockup of before and after

From the Department of Alignment and Agriculture.
The alignment between the text in the tree headers and tree cells are a bit off.
This mockup shows the Linux theme, but the issue is present in the Windows and Mac themes as well.
(Reporter)

Updated

6 years ago
Blocks: 667235
(Assignee)

Comment 1

6 years ago
Created attachment 563955 [details] [diff] [review]
Align the text

This patch aligns the text and the columnheader like in the mockup. I also aligned the AB headers.

Under Mac AB this looks a little bit weird because the names with the icons have a large left margin. I aligned the title with the text. When the title should align with the icon, then a padding of 22px would do this.

Under Windows I added a padding of 2px for the flaggedCol (the star) to align it better with the header.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #563955 - Flags: ui-review?(nisses.mail)
Attachment #563955 - Flags: review?(nisses.mail)
(Assignee)

Comment 2

6 years ago
Created attachment 564032 [details] [diff] [review]
Align the text v2

Oversaw the subject padding is different with threading enabled/disabled. New patch adapted to this.

Mac AB padding question still present.
Attachment #563955 - Attachment is obsolete: true
Attachment #563955 - Flags: ui-review?(nisses.mail)
Attachment #563955 - Flags: review?(nisses.mail)
Attachment #564032 - Flags: ui-review?(nisses.mail)
Attachment #564032 - Flags: review?(nisses.mail)
(Reporter)

Comment 3

6 years ago
Created attachment 564155 [details]
screenshot of the issue

All the headers looks good, except the header Subject.
(Assignee)

Comment 4

6 years ago
Created attachment 564159 [details] [diff] [review]
Align the text v3

Sorry I haven't thought Mac is different to Linux Win and is using other paddings in main and search window :(. Starting my Mac VM is a pain with a 1.6GHz processor and 768MB for the VM. So I decided to change the padding according Linux and Win without checking.
Attachment #564032 - Attachment is obsolete: true
Attachment #564032 - Flags: ui-review?(nisses.mail)
Attachment #564032 - Flags: review?(nisses.mail)
Attachment #564159 - Flags: ui-review?(nisses.mail)
Attachment #564159 - Flags: review?(nisses.mail)
(Reporter)

Comment 5

6 years ago
Created attachment 564176 [details]
Win7 HC misalignment

There is also a bit of misalignment when using the HC theme (here at 150% zoom, zoom worked well with Aero and Aero Basic btw). Misalignment marked in red. Not sure it's really caused by this patch, since the text used to be very off, but it seems to affect the starring column as well.
This issue is also present in the classic theme.
(Reporter)

Comment 6

6 years ago
Comment on attachment 564159 [details] [diff] [review]
Align the text v3

The mac alignment now works properly, but marking to review minus due to the Windows HC/Classic theme issue.
Both LTR and increase text size to 125% works as it should btw.
Attachment #564159 - Flags: ui-review?(nisses.mail)
Attachment #564159 - Flags: ui-review-
Attachment #564159 - Flags: review?(nisses.mail)
Attachment #564159 - Flags: review-
(Assignee)

Comment 7

6 years ago
Created attachment 564214 [details] [diff] [review]
Align the text v4

The classic themes under Win7 make all a little bit complicated, but now it should work. Tested also under XP.
Attachment #564159 - Attachment is obsolete: true
Attachment #564214 - Flags: ui-review?(nisses.mail)
Attachment #564214 - Flags: review?(nisses.mail)
(Reporter)

Comment 8

6 years ago
Comment on attachment 564214 [details] [diff] [review]
Align the text v4

Works excellent in both HC and Classic now!
Attachment #564214 - Flags: ui-review?(nisses.mail) → ui-review+
(Reporter)

Comment 9

6 years ago
Comment on attachment 564214 [details] [diff] [review]
Align the text v4

Thanks to Neil on irc I now know that [primary="true"] is for the thread lines.

From what I can see, an extra blank line got added in gnomestripe/mail/mailWindow1.css on line 283/284, review+ with that fixed.
Attachment #564214 - Flags: review?(nisses.mail) → review+
(Assignee)

Comment 10

6 years ago
Created attachment 564578 [details] [diff] [review]
Patch for check-in

Removed the unneeded line as in previous comment noted.
Attachment #564214 - Attachment is obsolete: true
Attachment #564578 - Flags: ui-review+
Attachment #564578 - Flags: review+
(Assignee)

Updated

6 years ago
Keywords: checkin-needed
OS: Linux → All
Checked in: http://hg.mozilla.org/comm-central/rev/ee2d1f664a9d
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 10.0
(Reporter)

Updated

6 years ago
Duplicate of this bug: 562086
Depends on: 807787
You need to log in before you can comment on or make changes to this bug.