search drop-down does not work while on an about: page

VERIFIED FIXED in Firefox 9

Status

Fennec Graveyard
General
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: ttaubert, Assigned: mbrubeck)

Tracking

({regression})

Firefox 9
Firefox 9
regression

Details

(Whiteboard: [has patch])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
STR:

1) Ensure Fennec is closed.
2) Start Fennec (about:fennec is shown)
3) Type a search term into the url bar
4) Click the magnifier icon at the very right
5) Select "Google"

Expected Result:

Google search for the given search term is done.

Actual Result:

A blank page is shown.
(Assignee)

Comment 1

6 years ago
I can reproduce this in desktop Fennec.  It looks like this happens any time you use the search engine menu while a local tab ("about:" or "chrome:" page) is selected.
Assignee: nobody → mbrubeck
tracking-fennec: --- → ?
status-firefox9: --- → affected
Keywords: regressionwindow-wanted
OS: Android → All
Hardware: ARM → All
Summary: search drop-down does not work first time after a cold start → search drop-down does not work while on an about: page
(Assignee)

Comment 2

6 years ago
Regression from bug 685440.
Blocks: 685440
Status: NEW → ASSIGNED
status-firefox8: --- → unaffected
Keywords: regressionwindow-wanted
Version: Trunk → Firefox 9
(Assignee)

Comment 3

6 years ago
Created attachment 562794 [details] [diff] [review]
patch

The bug is caused by the inadequate check for postData in loadURI, which threw an exception when aParams.postData was null.

The other changes are just minor fixes to related code.
Attachment #562794 - Flags: review?(mark.finkle)
(Assignee)

Updated

6 years ago
Whiteboard: [has patch]
Attachment #562794 - Flags: review?(mark.finkle) → review+
We'll want this in Fx9 (Aurora)
tracking-fennec: ? → 9+
(Assignee)

Comment 5

6 years ago
Comment on attachment 562794 [details] [diff] [review]
patch

Pushed to inbound:
https://hg.mozilla.org/integration/mozilla-inbound/rev/45e745c780d7

Requesting approval-mozilla-aurora for Firefox 9.  This fixes a regression introduced in Firefox 9 that breaks searching from the address bar in some common situations.  The fix is mobile-only and very safe.  It just adds a null check before accessing a property.
Attachment #562794 - Flags: approval-mozilla-aurora?

Updated

6 years ago
Attachment #562794 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 6

6 years ago
Pushed to Aurora for Firefox 9:
https://hg.mozilla.org/releases/mozilla-aurora/rev/2b4f99e468aa
status-firefox9: affected → fixed
Target Milestone: --- → Firefox 9

Updated

6 years ago
Whiteboard: [has patch] → [has patch], [QA+]
https://hg.mozilla.org/mozilla-central/rev/45e745c780d7
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: Firefox 9 → Firefox 10
This issue is not reproducible anymore on the latest Aurora build, but I was able to reproduce it on the latest Nightly build.

--
Mozilla/5.0 (Android;Linux armv7l;rv:9.0a2)Gecko/20110928
Firefox/9.0a2 Fennec/9.0a2
Device: Samsung Galaxy S
OS: Android 2.2

Mozilla/5.0 (Android;Linux armv7l;rv:10.0a1)Gecko/20110928
Firefox/10.0a1 Fennec/10.0a1
Device: Samsung Galaxy S
OS: Android 2.2
(In reply to Cristian Nicolae (:xti) from comment #8)
> This issue is not reproducible anymore on the latest Aurora build, but I was
> able to reproduce it on the latest Nightly build.
> 
> --
> Mozilla/5.0 (Android;Linux armv7l;rv:9.0a2)Gecko/20110928
> Firefox/9.0a2 Fennec/9.0a2
> Device: Samsung Galaxy S
> OS: Android 2.2
> 
> Mozilla/5.0 (Android;Linux armv7l;rv:10.0a1)Gecko/20110928
> Firefox/10.0a1 Fennec/10.0a1
> Device: Samsung Galaxy S
> OS: Android 2.2

09/28's Nightly was built off of 7f4867717226, this landed with 45e745c780d7 which didn't make the Nightly build. Check this again tomorrow.
(Assignee)

Updated

6 years ago
Target Milestone: Firefox 10 → Firefox 9

Comment 10

6 years ago
Mozilla/5.0 (Android;Linux armv7l;rv:9.0a2)Gecko/20110929
Firefox/9.0a2 Fennec/9.0a2
Device: HTC Desire Z
OS: Android 2.3

Mozilla/5.0 (Android;Linux armv7l;rv:10.0a1)Gecko/20110929
Firefox/10.0a1 Fennec/10.0a1
Device: HTC Desire Z
OS: Android 2.3

Verified on both Nightly and Aurora, and issue is not reproducing.
Status: RESOLVED → VERIFIED
status-firefox10: --- → fixed
Whiteboard: [has patch], [QA+] → [has patch]
With the steps from comment 0, I cannot reproduce this issue on the LG Optimus Black, using Android OS 2.2.2, using the 10b1 build from:
http://ftp.mozilla.org/pub/mozilla.org/mobile/candidates/10.0b1-candidates/build1/unsigned/
So marking status-firefox10-verified.
status-firefox10: fixed → verified
You need to log in before you can comment on or make changes to this bug.