The default bug view has changed. See this FAQ.

countrywide.com - [LAYER]JavaScript Pop-ups don't work appear

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English US
P3
trivial
RESOLVED WORKSFORME
16 years ago
2 years ago

People

(Reporter: edburns, Assigned: Doron Rosenberg (IBM))

Tracking

Details

(Whiteboard: [PROPRIETARY-DOM][aok], URL)

(Reporter)

Description

16 years ago
This occurrs on both the Netscape_20000922_BRANCH and on the trunk.


Steps to reproduce:

1. Visit http://www.countrywide.com/

2. After the page loads, move the mouse over the "we are a direct lender"
text.

Expected results: a "pop-up" like thingy appears displaying the text "no
middlement means less read tape...".

Actual results: nothing happens

Reproducible: always.

Comment 1

16 years ago
This appears to be a problem with browser detection code. It is looking for 
document.all and document.layers which will fail with Mozilla.

Updated

16 years ago
Assignee: rogerl → evangelism
Component: Javascript Engine → Evangelism
QA Contact: pschwartau → zach

Comment 2

16 years ago
That's right - Layers and document.all with no code path for DOM-compliant 
browsers. For example, here is the browser-sniffing being used at the site: 

                
          NS4 = (document.layers) ? 1 : 0;
          IE4 = (document.all) ? 1 : 0;
          ver4 = (NS4 || IE4) ? 1 : 0;


And then they have functions like this: 


// Function to 'activate' images.
function imgOn(imgName) {
  if (!ver4) return;

  if (NS4) {
    document.MainBodyDiv.document[imgName].src = eval(imgName + "_on.src");
  }
  else {
    document[imgName].src = eval(imgName + "_on.src");
  }
}



In Mozilla or NN6, the site's flags NS4, IE4, ver4 evaluate to false
(NN4.x supported layers, but Mozilla/NN6 does not). Therefore functions
like imgOn() don't run as expected in Mozilla/NN6. 


For more information on this issue, see bug 50711. Reassigning to 
Evangelism component - 

Updated

16 years ago
Summary: JavaScript Pop-ups don't work appear → [LAYER]JavaScript Pop-ups don't work appear

Comment 3

16 years ago
Agreed evangelism issue.

comments:
--------
* not affects the user access experience. I mean have access to pages.

* expand collapse menu does not work on secundary pages (but not affects user
access experience too because the submenus are already open using Mozilla).

Recommends to use the Ultimate Client Sniffer:
http://www.mozilla.org/docs/web-developer/sniffer/browser_type.html
to sniff the client


And if(is_gecko) { 	// see above URL.

then do the proper DOM operations with the elements in the page.

For example.. functions like this:
------
 function popUpHide(whichDiv) {
			if (!ver4) return;
			if (pageLoaded != 0) {
				if (NS4) {
				    eval ("document." + whichDiv + ".visibility = 'hidden'");
				}
				else {
				    eval (whichDiv + ".style.visibility = 'hidden'");
				}
			}
				
		}

proposed should be more like:

 function popUpHide(whichDiv) {
			if (!ver4) return;
			if (pageLoaded != 0) {

				if (is_gecko) {
					document.getElementById(whichDiv).style.visibility='hidden';
				}
				if (NS4) {
				    eval ("document." + whichDiv + ".visibility = 'hidden'");
				}
				else {
				    eval (whichDiv + ".style.visibility = 'hidden'");
				}
			}
				
		}

Updated

16 years ago
Assignee: evangelism → bclary

Comment 4

16 years ago
Reassigning evangelism bugs to bclary@netscape.com.

Updated

16 years ago
Priority: -- → P3

Updated

16 years ago
Summary: [LAYER]JavaScript Pop-ups don't work appear → countrywide.com - [LAYER]JavaScript Pop-ups don't work appear

Comment 5

16 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified
(Assignee)

Comment 6

16 years ago
the pop-up in question is gone, though the img hover effects still does not work
(the dhtml menus when you click the images works though).
Whiteboard: [PROPRIETARY-DOM]
(Assignee)

Comment 7

15 years ago
also need to upgrade hiermenu from 4.0.x to 4.1.x
Blocks: 85104
Whiteboard: [PROPRIETARY-DOM] → [PROPRIETARY-DOM][aok]

Comment 8

15 years ago
Mass reassign of all tech-evangelism us general bugs assigned to bc to 
doron except bc's P1 bugs. You may search for this mass reassign (it is 
305 bugs) by searching for the keyword 'greeneggsandham'
Assignee: bclary → doronr

Updated

15 years ago
Severity: normal → trivial
Site redesign. The new version supports W3C DOM. Marking as WorksForMe
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.