"open in new window" on a bookmark folder corrupts profile to make Ctrl+B always hang

VERIFIED WORKSFORME

Status

SeaMonkey
Bookmarks & History
P1
critical
VERIFIED WORKSFORME
18 years ago
14 years ago

People

(Reporter: Jesse Ruderman, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
mozilla0.9
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Steps to reproduce:

1. Back up your profile.
2. Ctrl+B.
3. Right-click on a folder in the manage bookmarks window, and select "open in 
new window".

Result: new window opens with that folder as the "hidden root".  (why hidden?)

4. Close both bookmarks windows.
5. (optional) Ctrl+B.

Result: mozilla hangs.

6. Restart Mozilla.
7. Ctrl+B

Result: mozilla hangs.

Deleting all of the files in my profile directory except for bookmarks.html 
fixes the problem.
(Reporter)

Comment 1

18 years ago
And if you have the Bookmarks panel open in the sidebar, Mozilla hangs on 
startup after step 6.
I don't see this. Any additional steps?

Comment 3

18 years ago
Marking nsbeta1+, p1, mozilla0.9
Keywords: nsbeta1+
Priority: -- → P1
Target Milestone: --- → mozilla0.9
I'm pushing this off or closing as worksforme unless I can reproduce this (which 
I currently can't). Can I get a bookmarks file attached that I can use to repro?
my warnings were not heeded! WORKSFORME. 
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

17 years ago
Works for me too with 041408, so verifying.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.