jQuery UI Blues: A CSS z-index & layer transparency Issue!

VERIFIED WORKSFORME

Status

Camino Graveyard
General
VERIFIED WORKSFORME
7 years ago
7 years ago

People

(Reporter: keith.mcfarlane, Unassigned)

Tracking

1.9.0 Branch
x86
Mac OS X

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 562831 [details]
The English Bookshop Popup.html

User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.7; en; rv:1.9.0.19) Gecko/2011091218 Camino/2.0.9 (MultiLang) (like Firefox/3.0.19)
Build ID: 2011091218

Steps to reproduce:

Built a relatively simple jQuery UI XHTML page that opens a new Camino tab. Opening the XHTML pages results in a jQueryUI modal pop-up being presented that itself contains a <form> object. For the example file (not optinised in terms of tracking the exact cause) see the attached file.


Actual results:

The XHML page opens as expected, and on pressing the <form>-submit button a second tab opens, again as expected. However on pressing the tab to return to the first page the jQuery UI transparent layer (but not the actual pop-up) are still present. This prevents the use of the web-page! In addition, the second tab can sometimes be seen beneath the transparent pop-up background layer.




Expected results:

The XHML page opens, and on pressing the <form>-submit button a second tab opens.Oon pressing the tab to return to the first page the jQuery UI transparent layer as well as the actual pop-up are removed.,, allow "first responder" access to the underlying the web-page!

 Note that the attached code works correctly on PC, iPad & Mac with Safari, FireFox, Opera, and (where appropriate) IE8 / 9.
(Reporter)

Comment 1

7 years ago
This is the second issue with the apparently simple use of jQuery / jQuery UI I have noticed. Because of jQuery's popularity we may expect Camino users to find such issues increasing frequent and therefore annoyingg. Perhaps some agreement on testing amd / or jurisdiction is required between the teams to iron out these (probably small) problems that can nonetheless screw up the user experience!

Updated

7 years ago
Attachment #562831 - Attachment mime type: text/plain → application/xml

Comment 2

7 years ago
I don't see any form in the attached testcase, but does this work properly in Camino 2.1b2 (or in Firefox 3.6)? It's very likely a Gecko 1.9.0 issue that is never going to be fixed there, but works fine in Gecko 1.9.2, on which Camino 2.1 is based.
(Reporter)

Comment 3

7 years ago
The form is embed in the pop-up. The XHTML code fragment inside (in the attached file) is as follows: 

  <div id = "EnglishBookshopPopUpDialog" style = "display: none;" title = "Take The English Bookshop Survey!" >
   <form action = "https://www.negativeentropy.net/" method = "post" title = "Feedback Form" >
    <div>
     <input type = "button" name ="Take Survey" value = "Take Survey" title ="Take the Survey" />
     <input type = "hidden" name = "request" />
     <input type = "submit" name = "submit" style = "display: none;" />
    </div> 
    <p style = "margin-bottom: 5mm; text-align: justify;" >
     FREE CREAM TEA FOR ONE! Be sure to print out &amp; keep a copy of your answers when the survey is completed! 
     Bring this to The English Bookshop and exchange it for tea, scones, jam and cream. The offer is one 
     English cream tea per person per survey. 
    </p>
   </form>
  </div>


 jQuery UI transforms this part of the DOM into a suitable pop-up with embedded content. I'm of course pleased that all works correctly in Camino 2.1b, BUT WHEN CAN WE EXPECT THIS TO BE RELEASED AND WHERE CAN I GET THE beta-release version now (if it's available)!!

Comment 4

7 years ago
What pop-up? The STR here are totally unclear, if the attached file is indeed supposed to be an example of what's broken.

http://preview.caminobrowser.org/ always has details on upcoming releases of Camino.

Since you know what you're expecting to happen, you probably need to be the one to tell us whether it works in Camino 2.1 (or Firefox 3.6), or you need to provide us with much clearer steps to reproduce using the file you've attached here.
(Reporter)

Comment 5

7 years ago
I have now downloaded the 2.1b version, and can confirm that the example XHTML file works correctly. As to  the example being "unclear", well it is a matter of a moment to load the attachment in FireFox, Chrome or other advisedly "correct" browser. 

 A couple of questions for you: (i) you are clearly aware of deficiencies in Gecko 1.9.0, why not upgrade the current Camino release to the later 1.9.2, at least as a useful stop gap?  (ii) when do we expect to see the formal release of Camino 2.1: it seems to me that that will fix a great many issues with jQuery. (iii) Do you test with jQuery (you should!)?

Comment 6

7 years ago
>As to  the example being "unclear", well it is a matter of a moment to load
> the attachment in FireFox, Chrome or other advisedly "correct" browser.

Clicking on the attachment link in this bug in Chrome, or Firefox 6, does nothing resembling popping anything up. The testcase does not appear to work correctly as posted.

(i) Upgrading from Gecko 1.9.0 to 1.9.2 was a very substantial undertaking, despite what the Gecko versioning might suggest. Camino 2.0 updated to Gecko 1.9.2 is the core of what Camino 2.1 is, so your question is essentially "Why don't you call Camino 2.1 Camino 2.0.x", and is thus not interesting to discuss.
(ii) As soon as we can. When your whole team is a handful of people working in their extremely limited free time, releasing isn't as easy as wanting to.
(iii) No; there's no point. Our web standards compatibility is controlled by our version of Gecko, and traditionally we've tried to stay current on our version of Gecko. The reason we're behind at the moment isn't that we don't know we should update, it's because we haven't had time (see ii).

FYI, questions that call into question our basic competence at running our project are pretty rude.


Closing WFM since it works in Camino 2.1.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME

Updated

7 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.