imdb.com - Fennec doesn't display mobile version of website on phone

VERIFIED WORKSFORME

Status

Tech Evangelism
Mobile
VERIFIED WORKSFORME
6 years ago
5 years ago

People

(Reporter: lmandel, Unassigned)

Tracking

({mobile})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [website-compatibility])

Description:
Navigating to http://imdb.com on my HTC Desire phone displays the full version of the site. There is a mobile version of the site that displays when using the default and Miren browsers. I expect that Firefox will also display the mobile version of the site. (Note that the full imdb site doesn't include a button to get to the mobile site. The mobile site can be viewed at http://m.imdb.com) The mobile version is preferable due to the small screen size.

Steps to reproduce:
1. Navigate to http://imdb.com

Actual results:
The full version of the site is displayed.

Expected results:
The mobile version of the site should be displayed.

Env:
Aurora 8.0a2
HTC Desire phone
Android 2.2
This bug is related to bug 688242.
Whiteboard: [website-compatibility]

Updated

6 years ago
Keywords: mobile
Assignee: english-us → nobody
Component: English US → Evangelism
Product: Tech Evangelism → Fennec Native
QA Contact: english-us → evangelism

Updated

6 years ago
blocking-kilimanjaro: --- → ?
We won't block on site specific issues. In this case we need to work with imdb.com to get them to redirect imdb.com to m.imdb.com when the site is accessed in Fennec.
blocking-kilimanjaro: ? → -
In disagreement, as bug 747123 does indicate that UA sniffing is part of a k9o user story. We need to discuss this to agree on what is and isn't a k9o blocker then, cause I don't think there is in general agreement on what we would or would not block on.
blocking-kilimanjaro: - → ?
In question for kilimanjaro, as this relates to mobile web compatibility. Note - We need to check where IMDB falls on the top sites scale to determine if this is important or not.
Removing the nomination flag, as I have not yet seen this site on our top apps/sites list. Re-nominate if it is.
blocking-kilimanjaro: ? → ---
Agreed. I think this is a nice to have as m.imdb.com works well for me on Fennec Aurora. It's likely still worth following up as imdb is currently ranked 44 globally (31 in the US) on Alexa.

Jean-Yves - Can you follow up on this issue?
Duplicate of this bug: 730740
Blocks: 764697

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Comment 8

5 years ago
Build ID: 17.0a2 (2012-10-08)Aurora Channel
          18.0a1 (2012-10-08) Nightly Channel
          19.0a1 (2012-10-09) Nightly Channel
Device: Samsung Galaxy Nexus / HTC Desire HD
OS: Android 4.1 / 2.3.3

Imdb.com is loaded in the mobile version . 
Marking bug verified as WFM.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

5 years ago
Component: Evangelism → Mobile
Product: Firefox for Android → Tech Evangelism
You need to log in before you can comment on or make changes to this bug.