Existing collections not visible any more

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Collector Extension
P2
normal
RESOLVED WONTFIX
7 years ago
2 years ago

People

(Reporter: Patrick, Assigned: kinger)

Tracking

BW-2.0
BW-2.1

Details

Attachments

(8 attachments)

(Reporter)

Description

7 years ago
Created attachment 562849 [details]
Empty page

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:6.0.2) Gecko/20100101 Firefox/6.0.2
Build ID: 20110905175240

Steps to reproduce:

Went to tools->add-ons->collections


Actual results:

an empty grid with 3 controls on the bottom left shows up for 1 second, then an empty page with 2 buttons


Expected results:

i should probably see my collections - shouldn't i ?
(Reporter)

Comment 1

7 years ago
Created attachment 562851 [details]
Empty Grid, visible for 1 second after opening the add-on tab, when "collections" selected before, when logged in
(Reporter)

Comment 2

7 years ago
I'm logged in on addons.mozilla.org, as well as with the extension, have 2 Collections à ~10 add-ons plus an empty "Favorite Add-Ons" collection...
Thanks Patrick. Can you please look in the Error Console after opening the collections tab. Post if there are any errors relating to the the collector?
(Reporter)

Comment 4

7 years ago
Negative. None. ... ???
(Assignee)

Comment 5

7 years ago
I see Greasemonkey is installed, so this bug could be the same as bug 689156. Although, that one is for Firefox 3.6.x.
Assignee: nobody → dave
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Target Milestone: --- → BW-2.0.3
Version: unspecified → BW-2.0
(Assignee)

Comment 6

7 years ago
(In reply to Patrick from comment #4)
> Negative. None. ... ???

Patrick, go to about:config and turn on the following 2 prefs:

- extensions.bandwagon.debug
- extensions.bandwagon.verbose

Then restart Firefox. When you start again you'll see a ton of 'bandwagon' related entries in the Error console. You should filter by 'Errors' and 'Warnings' to try and find suspicious output after trying the Colelctions pane.

You should then filter by All, and clear the Error console before opening the Add-ons Manager and Collections pane. In the lead up to the unexpected behaviour, even the Messages output might be useful.
(Reporter)

Comment 7

7 years ago
Created attachment 563018 [details]
Error Console

No interresting messages on firefox startup, this is what opening and closing (the last message) the add-ons tab with collections selected, with the bandwagon.{debug,verbose} options enabled produces....
(Reporter)

Comment 8

7 years ago
I have disabled greasemonkey btw - no change
(Assignee)

Comment 9

7 years ago
Patrick,

Are your collections public? If so, can you send me the links on AMO. I will subscribe and see if I can reproduce with them.
(Reporter)

Comment 11

7 years ago
Created attachment 567148 [details]
firefox console output, filtered: m/^bandwagon/

this is the bandwagon debug log after a fresh bandwagon install

what i did, was
 - quit firefox
 - mv .mozilla/firefox/default/sharing@addons.mozilla.org{,~}
 - mv .mozilla/firefox/default/extensions/sharing@addons.mozilla.org{,~}
 - start firefox
 - install addon collector
 - quit firefox
 - start firefox from the console
 - copy the output, paste in vim, type :g!/^bandwagon/d, :w debug.log, upload

no change - bug persists

 - quit firefox
 - start firefox from the console
 - copy the output, paste in vim, type :g!/^bandwagon/d, :w debug2.log, upload
(Reporter)

Comment 12

7 years ago
Created attachment 567149 [details]
firefox console output, subsequent run, filtered: m/^bandwagon/
(Reporter)

Comment 13

7 years ago
Created attachment 567152 [details]
https://addons.mozilla.org/en-US/firefox/api/1.3/sharing/?__=1318617170972

If i copy the second url in the log and open it with firefox, i am asked for a username/password for "AMO". If I type my amo credentials, I get this xml.
(Reporter)

Comment 14

7 years ago
the other url (?__=1318617167204) yields the same result. It looks a bit meager to me... I imagine the numbers beeing my collection id's and the xml might be supposed to contain their - ehr - contents. ... :-) that would mean it's a server problem...

I had a problem, if I recall correctly, when I first used the bandwagon addon also: i had to change my password using the web interface, because the addon didn't work, because my password contained special chars ... but no guarantees on this - it could have been with some other service as well ...
(Assignee)

Comment 15

7 years ago
Thanks for the information. There are no clues in the debug output you sent unfortunately.

I still can't reproduce when I subscribe to you collections.
(Reporter)

Comment 16

7 years ago
Created attachment 572555 [details]
xsession-errors

recently in my xsession-errors .... bug still persisting ... not sure if it's new - i'm just posting it because i spotted this auth error
(Assignee)

Comment 17

7 years ago
Could it be you logged in with an account that has no collections associated with it?

Output that makes me think so...

bandwagon(DEBUG): BandwagonCollectionsPaneController: about to repopulate the collections list

bandwagon(DEBUG): preferred collection is none

bandwagon(ERROR): [API]: error notifying observer: TypeError: collection is null
(Reporter)

Comment 18

7 years ago
no, it's the account that i gave you the url for - i'm using same email and password to login in the addon collector and on a.m.o .... just logged in & out again to make sure

the collections are there on a.m.o but not in the addon collector

:-) really funny bug ... what i never mentioned but, you never know, might even be connected, is that i'm a bit upset because a.m.o. allways shows me the german version first - i have my firefox set to german in preferences->content->preferred language --- for some specific reason i can't remember right now :-) --- but i generally prefer english and every other page i visit seems to set a cookie to save the descision, so that i at least only have to switch the language once, not _every time_ i visit.......... anyway ... not really a bit issue
(Reporter)

Comment 19

7 years ago
phaaa....

nobody told me and there is not even the slightest hint anywhere (well ... i'm mentally blind) that ... you .. have to f** WATCH ... your own collections

i don't watch my own stuff.

i use it.

this is idio.... :-) ... well - it's ok - found the reason at last (after starting with a fresh profile and creating a dummy account on amo) --- i get it -- you can have collections on amo that are invisible in bandwagon ... but ... well ... it's a bug !!!

:-)

another bug btw. is that you can't delete a collections description on amo - just change - but if you change to empty the change is never saved.


tzzz...
(Assignee)

Comment 20

7 years ago
(In reply to Patrick from comment #19)
> nobody told me and there is not even the slightest hint anywhere (well ...
> i'm mentally blind) that ... you .. have to f** WATCH ... your own
> collections

Aha!

> this is idio.... :-) ... well - it's ok - found the reason at last (after
> starting with a fresh profile and creating a dummy account on amo) --- i get
> it -- you can have collections on amo that are invisible in bandwagon ...
> but ... well ... it's a bug !!!

Can you elaborate a bit more what you mean by "invisble"? I'll need to investigate if it really is a bug or not.

> another bug btw. is that you can't delete a collections description on amo -
> just change - but if you change to empty the change is never saved.

That is a separate site bug that you will have to open separately.
Assignee: dave → briks.si
Target Milestone: BW-2.0.3 → BW-2.1
(Reporter)

Comment 21

7 years ago
Created attachment 577235 [details]
invisible personal collections

> Can you elaborate a bit more what you mean by "invisble"?

Yes. Well. Have a look at  the screenshot. IMHO it is a bug, that even though I have
3 own colections on amo, *associated with the username* that I provided to the addon
collector to log in, the "Collections:" vertical tab inside Firefox' "Add-Ons Manager"
tab (the white area with the "Welcome to the Add-on Collector" heading), as well as the
"Collections" page of the "Add-On Collector Settings" window are completely devoid of
those collections *and* there is no mention whatsoever about the reason why this is so.

Full disclosure: I have "unfollowed" my own collection on the amo website, *before*
installing the addons collector.

Possible solutions (not mutually exclusive):

1. add a textual clue somewhere and mention that Collections have to be followed in order to
   show up in Add-on Collector

2. instead of showing an "Welcome" page with a useless "Find Collections" hyperlink, disguised
   as a button, show the empty "wireframe" of the usual application interface

3. when clicking the "+" button on the bottom left in this hypotetically empty "Add-On Manager"'s
   "Collection" vertical tab, bring up a popup containing each of my own collections as an
   entry and one additional entry, saying something like "More..." that opens the amo
   website

4. Inside the "Collections:" list in the "Add-on Collector Settings" "Manage Collections" page,
   do not completely remove my own collections, even if i choose "Remove", but instead keep
   them in the list, gray them out, and add a means of "re-following" it from inside the settings
   window. Alternatively: add something similar to the "+" button popup described in 3.

> That is a separate site bug that you will have to open separately.

Not important enough enough to hit my action threshold atm...

-------

Despite the bug, I like this tool! :-) And am glad I can use it now.
(Assignee)

Comment 22

6 years ago
2.1 has been released today and it will be the final version of the Collector in its current form (A simple add-on just to load the Collections AMO page might replace it). This bug didn't make it in. So marking this as WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.