Disable hardware acceleration in Thunderbird

RESOLVED FIXED in Thunderbird 11.0

Status

Thunderbird
Preferences
RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: Joe Drew (not getting mail), Assigned: sid0)

Tracking

(Blocks: 1 bug, {perf})

unspecified
Thunderbird 11.0
x86
Mac OS X
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird9 fixed, thunderbird10 fixed)

Details

(Whiteboard: [battery][gs][gssolved], URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

6 years ago
Right now Thunderbird forces the use of the discrete GPU because it uses layers acceleration. OpenGL layers acceleration is probably of minimal utility on Thunderbird, and so it should be disabled.
(Reporter)

Comment 1

6 years ago
It's ok for this to be only for OS X, since that's where people are most badly affected by battery-life concerns from using the discrete GPU.

Comment 2

6 years ago
Corresponding Windows bug 667989, general discussion in bug 668552.
Blocks: 618868
Joe can you provide the patch ?
(Assignee)

Comment 4

6 years ago
Created attachment 563655 [details] [diff] [review]
patch

Let's just do it on all platforms.
Assignee: nobody → sagarwal
Status: NEW → ASSIGNED
Attachment #563655 - Flags: review?(mbanner)
(Assignee)

Comment 5

6 years ago
Mark, review ping?
Whiteboard: [battery]
this setting complicates helping users who may have performance issues unrelated to this setting.  So it would be nice to do this soon, and even push it down into version 9 (soon to be beta)


(In reply to Siddharth Agarwal [:sid0] from comment #4)
> Created attachment 563655 [details] [diff] [review] [diff] [details] [review]
> patch
> 
> Let's just do it on all platforms.

makes sense, because we have these other bug reports
Bug 693852 - High GPU usage with constant status bar animation and direct2d
Bug 668552 - Interface is unusable when GPU is busy ... Slow deletes, message viewing, address autocomplete
Bug 667989 - DirectWrite/Hardware Acceleration should be disabled by default (direct2d)
Keywords: perf
Created attachment 577709 [details] [diff] [review]
patch v2

Having had a few discussions, we've confirmed that hardware acceleration doesn't have any significant benefit for Thunderbird in its normal use cases. Therefore drivers have agreed to disable hardware acceleration.

There is a second preference involved on Windows (gfx.direct2d.disabled) that we want to disable alongside the layers one, so I've updated your patch to include that.

This has r+a=me. I'll land these in a bit as I think you're busy at the moment.
Attachment #563655 - Attachment is obsolete: true
Attachment #563655 - Flags: review?(mbanner)
Attachment #577709 - Flags: review+
Attachment #577709 - Flags: approval-comm-beta+
Attachment #577709 - Flags: approval-comm-aurora+
Summary: Set layers.acceleration.disabled to true → Disable hardware acceleration in Thunderbird
Checked in:

http://hg.mozilla.org/comm-central/rev/1d249939cafe
http://hg.mozilla.org/releases/comm-aurora/rev/786b3e3abd0f
http://hg.mozilla.org/releases/comm-beta/rev/2f77787a4916
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
status-thunderbird10: --- → fixed
status-thunderbird9: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 11.0
Duplicate of this bug: 667989
Duplicate of this bug: 668552
Duplicate of this bug: 693852

Comment 12

6 years ago
Great, this may fix a class of problems I was triaging.
However, just to be sure, will this disable also Direct2D usage?
It indeed does.

Updated

6 years ago
Blocks: 703437
Whiteboard: [battery] → [battery][gs][gssolved]

Comment 14

5 years ago
This will lead to Windows users that previously had Directwrite text rendering to have GDI rendering again which might look/behave differently.
bug 689742 comment 0 says the reason is that back then, GL layers triggered the discrete GPU on dual-GPU macs.

That's long not been the case anymore. You can safely turn on GL layers, that won't trigger the discrete GPU. What does trigger the discrete GPU is WebGL, and only during the lifetime of any WebGL context.

Comment 16

3 years ago
Yes, this was reverted in bug 950133.
Blocks: 950133
See Also: → bug 1131879
You need to log in before you can comment on or make changes to this bug.